j'ai un probleme d'erreur

j'ai un problème d'erreur, mais je ne pense pas que cela viennent de mon code.

Si quelqu'un peut m'aider il est le bien venu merci.

l'erreur:

Arduino : 1.8.5 (Windows Vista), Carte : "Arduino/Genuino Uno"

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp: In constructor 'RobotControl::RobotControl()':

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:26:42: error: 'LCD_CS' was not declared in this scope

RobotControl::RobotControl():Arduino_LCD(LCD_CS,DC_LCD,RST_LCD){

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:26:49: error: 'DC_LCD' was not declared in this scope

RobotControl::RobotControl():Arduino_LCD(LCD_CS,DC_LCD,RST_LCD){

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:26:56: error: 'RST_LCD' was not declared in this scope

RobotControl::RobotControl():Arduino_LCD(LCD_CS,DC_LCD,RST_LCD){

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp: In member function 'void RobotControl::begin()':

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:36:21: error: 'MUXA' was not declared in this scope

uint8_t MuxPins={MUXA,MUXB,MUXC,MUXD};

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:36:26: error: 'MUXB' was not declared in this scope

uint8_t MuxPins={MUXA,MUXB,MUXC,MUXD};

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:36:31: error: 'MUXC' was not declared in this scope

uint8_t MuxPins={MUXA,MUXB,MUXC,MUXD};

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:36:36: error: 'MUXD' was not declared in this scope

uint8_t MuxPins={MUXA,MUXB,MUXC,MUXD};

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:37:29: error: 'MUX_IN' was not declared in this scope

Multiplexer::begin(MuxPins,MUX_IN,4);

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:40:10: error: 'BUZZ' was not declared in this scope

pinMode(BUZZ,OUTPUT);

^

C:\Program Files\Arduino\libraries\Robot_Control\src\ArduinoRobot.cpp:43:2: error: 'Serial1' was not declared in this scope

Serial1.begin(9600);

^

exit status 1
Erreur de compilation pour la carte Arduino/Genuino Uno

Ce rapport pourrait être plus détaillé avec
l'option "Afficher les résultats détaillés de la compilation"
activée dans Fichier -> Préférences.

cela est urgent mon prof de techno récupère mon programme lundi.
merci.

la bonne blague ! et la note à la fin, elle est pour toi ou pour nous si on te débogue ton code ? Les messages d’erreurs sont assez clairs, pourtant…

désolé mais je ne comrend pas pas je commence juste a codé esque tu peut mexpliquer se que je dois faire
merci.

oups les fautes

de ce que je vois des erreurs qui sont données, il te manque une partie concernant un afficheur lcd dans la librairie "robot_control" que tu utilises. Peut-être que cette librairie en utilise une autre que tu n'a pas ?
en même temps, sans avoir ni ton code, ni les librairies utilisées... ça va être compliqué pour t'aider !

a oui effectivement
le code tout simple :
#include <ArduinoRobot.h>

void setup()
{
Robot.begin();
}
void loop()
{
Robot.motorsWrite(255, 255); //Make the robot go forward, full speed
delay(1000);
Robot.motorsWrite(0, 0); //Make the robot stop
delay(1000);
Robot.motorsWrite(255, -255); //Make the robot rotate right, full speed
delay(1000);
Robot.motorsWrite(0, 0); //Make the robot stop
delay(1000);
}

haaa en effet, le code est tout simple, et donc l’erreur vient de la libraire que tu utilises.

Elle vient d’où cette librairie ? c’est celle fournie par arduino ? Si c’est celle fournie par arduino, dans tous les exemples la librairie <Wire.h> est aussi incluse. Il manquerait donc un
#include <Wire.h>
dans ton code, juste après #include <ArduinoRobot.h>

pas certain que ça ait un rapport avec ton erreur, mais autant commencer par la base

sur se site il y a des tuto et j'ai copié collé un code pour l'essayer et le comprendre ducou normalement oui

J'ai un gros doute ...
Tu as le lien vers la librairie ?

tu veut le lien ou j'ai trouvé le code ?
si oui :
https://www.arduino.cc/en/Reference/RobotMotorsWrite

tu trouve ??

C'est bien ce que je craignais

Si tu avais regardé de plus prêt, tu te serais apperçu que cette librairie n'est pas utilisable avec un Genuino Uno elle est spécifique à la carte Arduino Robot

La Genuino Uno et la Arduino Robot ne sont pas constrites autour du même µcontrolleur

Carte que tu retrouve dans l'IDE dans le menu "Outils" / "Type de carte" / "Arduino Robot Motor" ou "Arduino Robot Control"

J'ai l'impression que tu vas être à la bourre pour lundi

a esque s’est possible de l’utilisé quand même?
sinon peut tu m’expliquer comment faire pour faire avancer reculer droite gauche pour un robot ??
vraiment merci a toi.

Impossible de l'utiliser.
La Arduino Robot à une organisation matérielle totalement différente de la Genuino Uno
Elle comporte de nombreux périphériques matériel que la Uno n'a pas (Afficheur LCD, clavier, haut parleur, compas, potentiomètre, interface carte SD, ...)

sinon peut tu m'expliquer comment faire pour faire avancer reculer droite gauche pour un robot ??

Il faut reprendre le projet de zéro
Tu as prévu quoi ?
Quels sont les capteurs et actionneurs prévus ?
Quelles sont les entrées/sorties ?
Quelles broches vas-tu utiliser ?
Faut-il une interface électronique en entrée ou en sortie pour chaque broche ?
Quelle(s) librairie(s) devras-tu utiliser ?
As-tu une idée de l'organisation globale du code ?
As-tu déjà fait des essais de code simple pour chacune des entée ou sortie ou librairie ?

Si tu n'es pas capable de répondre oui à chacune des questions, le projet ne pourra jamais être réalisé en 2 jours

je veut juste savoir comment déplacer un un robot geore la ligne de code après je me débrouille pour voir si ji arrive et je demande si je ni arrive pas.
sur ce slt a demain

La ligne de code c’est analogWrite(enable, vitesse);enfin, quelque chose comme cela...

On ne sait rien de votre robot comment voulez vous qu’on vous aide?

Pour le déplacer il faut envoyer des ordres aux moteurs. Vous pouvez donc lire les tutos d’eskimons sur les moteurs...

Mais si c’est pour lundi et que vous pensiez vous en sortir en piquant du code sur internet sans rien comprendre, c’est assez mal barré...c’est pas le moment d’aller dormir, faut bosser...

mathmath:
je veut juste savoir comment déplacer un un robot geore la ligne de code après je me débrouille pour voir si ji arrive et je demande si je ni arrive pas.
sur ce slt a demain

T'es pas dans Harry Potter, il faut pas croire que des petits lutins vont venir faire le boulot à ta place pendant le week-end

Désolé pour hier je devais absolument me couché (a cause de mes parent).
Les port pour les moteur sont M1 M2, j'ai un robot Mbot-Blue.
Ne vous inquiétez pas je comprend a peut près j'ai déjà fait de la programmation mais pas avec des robot.

et peut-être en utilisant le logiciel prévu pour le mbot alors ??
http://www.mblock.cc/