Java exception error when Starting arduino IDE 1.8.5 on Windows 8.1

Hello,

My first experience in the Arduino world has not been that fine so far… I installed version 1.8.5 of the Arduino IDE on my Windows 8.1 and it didn’t launch properly. Only the splash screen appears and disappears immediatly. I then started arduino_debug.exe and this is what I obtained :

java.lang.ExceptionInInitializerError
at processing.app.Platform.setLookAndFeel(Platform.java:82)
at processing.app.Base.(Base.java:224)
at processing.app.Base.main(Base.java:144)
Caused by: java.lang.IllegalArgumentException: 33 incompatible with Text-specific LCD contrast key
at java.awt.RenderingHints.put(RenderingHints.java:1075)
at sun.awt.windows.WDesktopProperties.getDesktopAAHints(WDesktopProperties.java:312)
at sun.awt.windows.WToolkit.getDesktopAAHints(WToolkit.java:1035)
at sun.awt.SunToolkit.getDesktopFontHints(SunToolkit.java:1860)
at sun.awt.windows.WDesktopProperties.getProperties(WDesktopProperties.java:249)
at sun.awt.windows.WToolkit.lazilyInitWProps(WToolkit.java:911)
at sun.awt.windows.WToolkit.lazilyLoadDesktopProperty(WToolkit.java:900)
at java.awt.Toolkit.getDesktopProperty(Toolkit.java:1803)
at javax.swing.UIManager.(UIManager.java:380)
… 3 more

Well, I am not sure to understand exactly what it means…

Is there something to do to solve this issue ?

Regards,

David

Don't use Windows app. Use Windows installer version.

That’s what I first did, I used the Windows installer. But I also tested the .zip archive. With both methods I get the same java exception error :frowning:

I only have installed the IDE on Windows 7, 10, and Linux. Never Windows 8.1

Though I am not sure why Windows 8.1 would be that different from 7 and 10.

I also have colleagues around me having installed on Windows 7, 10 and Linux without any problem. And to be honest, I first tried to download the Windows app from the Arduino download page, but even if it is supposed to require Windows 8.1 or 10, when I enter the download page with my Windows 8.1 computer, the "Get the App" download button is not active and the following message is displayed :

"This app does not work on your device."

Very fun, given that I run Windows 8.1

You might run windows 8.1 but on what type of hardware ?
Tablets are a PITA to get Arduinos running with.

I don't use any exotic hardware but a standard Core i7 Asus laptop.

Seems maybe related: https://www.rarst.net/software/cleartype-install4j-java-bug/ That says this error can be caused by your ClearType settings. Try turning ClearType off (assuming you have it on) temporarily to see if the problem goes away.

I believe you can find the setting via Start > Search > Adjust ClearType text

Hey Pert, you hit the nail right on the head, congrats !!!

I don’t know how you came to this, but you have just relieved my headache :wink:

Thank you very much the problem is solved.

King regards,

David

Glad to hear it! I'm kind of surprised myself. I've seen a ton of errors from the Arduino IDE but this was the first time I saw that one.

Enjoy, Per

Why only in Windows 8.1 and not 7 or 10 ?

I'm not certain it's limited to Windows 8.1. The link in my previous reply said they found their ClearType contrast setting value was "gibberish" and when they changed it to a valid value (probably just by moving the slider in the ClearType Tuner program) the problem was resolved. I suspect if that value was corrupted the same problem would happen regardless of OS version. The question is how did that value get corrupted? I have no idea, and that could be an OS version-specific thing.

@David-san if you do want to turn ClearType back on you could give that a try. I don't think the conclusion is that ClearType and Arduino are incompatible but turning it off seemed to be the best initial troubleshooting step to me. Now that you've narrowed down the cause to ClearType it's easier to proceed to finding the exact cause of the problem if you're so inclined.

How does ClearType Tuner get corrupted? I didn't even know such a thing existed. Pretty sure the Average Joe/Jane is even more in the dark.

.

@Pert: OK, I turned ClearType back on and recalibrated it according to my own viewing pleasure :wink: … and guess what… it now works perfectly with the Arduino IDE. I have seen strange things in my live, but this is really really strange…