java.lang.NullPointerException Problem

I've been using the Compiler for a long time with no problems now all of the sudden I'm getting the following errors :

      at java.awt.event.InvocationEvent.dispatch(
      at java.awt.EventQueue.dispatchEvent(
      at java.awt.EventDispatchThread.pumpOneEventForFilters(
      at java.awt.EventDispatchThread.pumpEventsForFilter(
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(
      at java.awt.EventDispatchThread.pumpEvents(
      at java.awt.EventDispatchThread.pumpEvents(

I'm searching for the latest java update now to see what happens. I tried uninstalling the compiler and reinstalling just to get the same problem. Looking to see if anyone else has had this problem and found a fix. If it helps I'm running Windows 7 64-Bit. I usually don't have problems figuring this stuff out but I'm puzzled right now.I have tried to just verify every simple sketch included and some I wrote and this occurs. If I try to upload it's the same as well. The java update did nothing.

Well I got it working again, after another update and cleaning out some temp folders.

I get those errors maybe 1 out of every 10 times. Usually I just hit compile again and it's good to go. Was the problem occurring every time?

I’m still having the same problem what should we do to solve it?

Does the problem persist no matter what sketch is being edited?

I'm having the same problem! can anyone help us?

I'll ask the same question I asked earlier. Does this exception occur when compiling any sketch, or only a specific sketch?

If it is a specific sketch, post it.


This occur when compiling any sketch (like the blink one)

I got a java.lang.NullPointerException when I reinstalled the Arduino IDE and tried to compile a sketch without selecting a hardware board. Make sure something (e.g. Duemilanove with ATmega328) is selected under the Tools, Board menu first.



Congratulations Andrew, you solved the problem!


Yay! :)