Java Runtime Environment file missing or corrupted.

I have never had any problems with any version of the Arduino program I ran on my laptop, until yesterday.

Now, I get the following error dialog--

"This application was configured to use a bundled Java Runtime Environment but the runtime is missing or corrupt."

I uninstalled the Arduino program and reinstalled from a WinZip file I got off the Arduino website, still no luck.

What is the fix, please?

Thank You,
Douglas E. Mays

Which version are you using?

Arduino support reported earlier today, 6/10/2020:

We had a problem on our package_index.json file which caused the current error and it has prevented the IDE to start. Now the package_index.json file has been fixed, but to recover a working installation you must delete once again the package_index.json and restart the IDE as usual.

You can find the package_index.json usually in the following folders:
Windows:

[color=#2b2e2f]remove file C:\Users\YourUsername\AppData\Local\Arduino15\package_index.json
remove folder C:\Users\YourUsername\AppData\Local\Arduino15\cache[/color]

Mac:

[color=#2b2e2f]remove file /Users/YourUsername/Library/Arduino15/package_index.json
remove folder /Users/YourUsername/Library/Arduino15/cache[/color]

Linux:

[color=#2b2e2f]remove file: /home/YourUsername/.arduino15/package_index.json
remove folder /home/YourUsername/.arduino15/cache[/color]

Please note that the problem that prevents the IDE to start has already been fixed for the next releases, that's the reason why the Nightly/Beta Builds are not affected, and also the reason why we did not detect the problem earlier,

Thanks for the help!!

Ver. 1.8.11

Removing the package_index.json files did not work.