Jerky motion/incorrect code reading when DC wall adapter is used as power source

Hello all,

I am using an arduino uno, with an adafruit motor shield v1.2, (2) 200 step bi polar stepper motors (Pololu - Stepper Motor: Bipolar, 200 Steps/Rev, 35×36mm, 2.7V, 1 A/Phase) and 4 momentary push buttons with leds (http://www.exp-tech.de/accessories/Button-Switch/Waterproof-Metal-Pushbutton-with-White-LED-Ring-16mm-White-Momentary.html)

I have written a code that will spin both motors simultaneously (or alternating one step at a time) a certain amount of steps when each button is pressed to reach the desired position. Everything works perfectly when i have the USB plugged into my computer and even when i remove the USB and connect a battery pack with 6 AA batteries to the motor shield.

The problem is the batteries die rather quickly, so i want to just plug it into the wall to power everything. I have tried 3 different DC wall adapters and each one does the same thing. When the button is initially pressed, everything seems to be working fine, however after about half a rotation the motors become very jerky, as if they didnt have enough power to spin the gear.

these are the specs for the wall mounts. i used the 9V 2.0A, 12V 2.0A, and the 12V 2.5A

Any and all help is much appreciated. Thanks in advance!!

Is the wallpack providing juice for

  • the motor
  • the motor and the adafruit board
  • everything (the Arduino incl.) ?

I want it to provide power for everything. Ive tried plugging it into the arduino as well as the motorshield and i get the same results either way.

also im sorry, i forgot to paste the link for the wall mount specs

http://www.sunny-euro.com/data/files/ae0ffb14b00c61bc1413443cb0d8144f.pdf

thanks,
Kev

How much current are you putting into each winding? Are you driving one winding at a time or both
simultaneously or microstepping? If each winding takes 1A and you use full-wave drive (both windings),
then each motor takes 2A all the time, so a 4A supply would be a bare minimum (not allowing for anything else).

You'd likely do far better with something like a Polulu A4988 bipolar driver and a 12V or 24V motor supply...