Hi, I am trying to program my Jewelbot on a Chromebook with the Arduino Create online IDE.

The online Arduino IDE is such a great tool, I wish there was a way to use custom boards like there is in the downloadable version of the program.

According to this thread it looks like it might be possible to program a Jewelbot by selecting the board "Arduino Gemma". However, I don't see that board as an option in Create.

Does anyone know if there is an existing board in the drop down menu that I can select to use with my Jewelbot?

Thanks for any help on this topic!

There is none. I believe you could do it with codebender:

Otherwise, you'll need to use the standard IDE on computer running a regular operating system.

Pert - thanks for the reply! The downloadable Arduino IDE does work excellently for Jewelbots, you're right. The one thing that is confusing me with codebender is how to upload the custom board.

Here are the links for the Jewelbots custom board:,,

And here is the page on codebender where custom boards can be uploaded:

I saved the linked JSON files as .txt files and tried the upload, but I keep getting "Error: File does not have the required structure."

I've actually never used codebender. I just saw it supported Gemma and Chrome so that's why I suggested it.

At the link you posted, I only see a list of the currently supported boards and a link to a forum request thread that doesn't work for me. Maybe I'm seeing something different from you because I'm not logged in? If you'll provide more information on the error you're getting I'll look into this as I am quite familiar with the workings of the Boards Manager JSON files.

Have you been able to successfully use the Gemma board option with your JewelBot?

Hi Pert,

pert: Have you been able to successfully use the Gemma board option with your JewelBot?

No. When I plug it in, codebender recognizes it as a "monteino" board. However, I never even get to the upload stage because it won't compile. I don't know how to get the Jewelbots library into the site so I can include the h files from it. Here is a picture so you can see the error I'm getting.

pert: If you'll provide more information on the error you're getting I'll look into this as I am quite familiar with the workings of the Boards Manager JSON files.

Yes! I think I need to know how to format the json file correctly!

The json files I am trying to use are from STEP 3 of this page

Steps I have tried: Saving the json files as .json files and uploading. This gets an error stating that the files must be .txt Saving the json files as .txt and uploading. This gets an error message stating the files are not formatted correctly. I have also tried uploading various files from the Jewelbots github here but without knowing what a properly formatted board file looks like I'm shooting in the dark.

Here is a screenshot of the error message since I believe it's only visible when I'm logged in with my paid account.

After some research I found that you were mislead by the other forum thread you posted. That was for a tutorial people from Jewelbots did to teach how to use the Arduino Gemma for wearables but it was not referring to the actual Jewelbots product. The Jewelbots product is completely different and much more advanced from the Gemma so you will definitely not be able to use your Jewelbots using the Gemma hardware definitions.

The Moteino is also completely different so you can’t use that board selection.

The picture you posted with the compiling error doesn’t show the whole error so I can’t give any specific help but it’s likely caused by trying to compile code that is not compatible with the Moteino board you have selected. Please always post error/warning messages to the forum as text, using code tags (</> button on the toolbar). If the text exceeds the 9000 character post limit you can add it as a .txt file attachment. Pictures of text are not helpful.

It turns out the “Add Personal Boards” option on only shows up when you’re logged in so that’s why I couldn’t see it before. I’m not finding any documentation at all from codebender for this feature. It’s really sad that they wouldn’t make the effort to publish some documentation. Lacking any information, I’m forced to guess that this is for uploading a boards.txt file, which will require that all other dependencies are already installed on codebender’s server. Since all the other boards listed on that page are AVR-based and the Jewelbots is a nRF51822 cortex-m0 I don’t believe that will work for you. I recommend you to post to the forum thread at the “request a board” link to see what they will say.

Thank you for your help, Pert! I suppose for now I'll stick with the downloadable Arduino IDE until someone creates a chrome book app that supports devices with the FT230X chip. :)

I don't think the FT230x is the problem. I'm guessing that's the USB-serial chip used on the Jewelbots? The problem is support for the toolchain required for the nRF51822 primary microcontroller on the Jewelbots. The classic Arduino boards use the ATmega AVR microcontrollers and a wide variety of those are supported by Codebender. There are also some more modern microcontrollers used on the newer Arduino boards, which are supported by the Arduino Web Editor but none of these boards use the nRF51822. The closest is the Arduino Primo, with the nRF52832.

Luckily the Arduino IDE was written so that it's very easy to add support for any microcontroller you like but unfortunately the Arduino Web Editor and Codebender are not so flexible. There have been a lot of requests for the Arduino Web Editor to be opened up to supporting 3rd party boards and the developers have not specifically said it won't happen but I also haven't heard of any immediate plans to add that feature. As for Codebender, at least they do have the request thread on the forum but I don't know how responsive they are to requests for non-AVR boards.