Kategorie '' in der Bibliothek ist ungültig und wird auf 'Uncategorized' fes

Hallo,

ich bekomme seit dem Update von 1.6.5 auf 1.6.6 beim kompilieren die folgende Fehlermeldung:

WARNUNG: Kategorie ‘’ in der Bibliothek … ist ungültig und wird auf ‘Uncategorized’ festgelegt

Das Programm läuft ohne Probleme, die Library ist unverändert und funktioniert seit einem Jahr ganz gut. Der Fehler tritt bei mehreren Librarys auf, auch fertigen aus dem Internet.

Leider kann ich keinen Hinweis finden, wo das Problem sein könnte und auch keine Log-Daten.

Gruß, Markus

Im Library Ordner haste ne Datei library.properties
Öffnen und eintragen zu Welcher Kategorie es passt.

zB TimeAlarms Library gehört zu:
category=Timing

Bei dir fehlt der Eintrag.

Hallo,

ja, das war der Fehler, ist erledigt.

Vielen Dank !

Gruß, Markus

Hi

Sorry für’s Aufwärmen - welche Kategorien gibt Es denn Alles?
Bei mir geht’s um die

name=FaBo PWM PCA9685
version=1.0.0
author=FaBo<info@fabo.io>
maintainer=Akira Sasaki<akira@fabo.io>
sentence=A library for FaBo PWM.
paragraph=PCA9685 is I2C PWM.
category=Communication
url=https://github.com/FaBoPlatform/FaBoPWM-PCA9685-Library
architectures=avr,esp32

Habe dort jetzt, statt dem originalem PWM → Communication eingetragen, seit Dem ist Ruhe.
Nur kommuniziert diese Lib ja nicht wirklich - ggf. hat diese Kategorie ja einen tieferen Sinn, daß Es ‘toll’ wäre, die Passende dort einzutragen.

MfG

Arduino IDE 1.5: Library specification