kein Upload auf UNO

Hallo da draußen,
habe jetzt schon den dritten UNO der sich nicht mehr über USB beschreiben lässt.
Mit dem ISP funktionieren aber alle noch.
Habe beim ersten noch an einen Kurzschluss gedacht aber die anderen sind im Gehäuse.
Beim anstecken an den USB Port wird immer noch eine COM zur Verfügung gestellt.
Hat jemand ne Idee ob ich die wieder zum laufen kriegen kann?

Gundelputz:
Hat jemand ne Idee ob ich die wieder zum laufen kriegen kann?

Ok, Standardfragen:

Was kommen für Fehlermeldungen ?
Hast du die Fragen geprüft ?
Hast du das Kabel gewechselt ?
Hast du den Treiber neu installiert ?
Hast du .... ??

Hast Du etwas an die Pins 0 und 1 angeschlossen?

Fehlermeldung:

Build-Optionen wurden verändert, alles wird neu gebaut

Der Sketch verwendet 2.802 Bytes (8%) des Programmspeicherplatzes. Das Maximum sind 32.256 Bytes.
Globale Variablen verwenden 53 Bytes (2%) des dynamischen Speichers, 1.995 Bytes für lokale Variablen verbleiben. Das Maximum sind 2.048 Bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x51
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x51
Probleme beim Hochladen auf die Platine. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload .

Welche Frage?
Kabel getauscht. Funktionieren an andern Systemen.
Treiber i.O. funktionieren auch nicht an anderem Rechnern.

am UNO ist z.Z. nicht angeschlossen

Welcher Com-Port wir zur Verfügung gestellt ?

Wie machst du den Upload ?

Mit Menü-Sketch hochladen ? Oder mit der Schaltfläche oder mit Strg+U ?

COM8(Arduino Uno)

Upload über Taste Hochladen oder Datei/Hochladen
habe es gerade noch mal mit Strg+U probiert kommt aber aufs gleiche raus

Wenn du den Uno per ISP beschreiben kannst, dann flashe doch mal einen neuen Bootloader auf den Uno.

Evtl. ist das der Fehler.

Mit dem ISP funktionieren aber alle noch.

wenn du den Sketch über ISP hochlädst, machst du den Bootloader platt, dann mußt du erest den Bootlader neu brennen.
Edit: zu Spät.

Bootloader über ISP funktioniert leider auch nicht aber wie mache ich dien "platt"?

Gundelputz:
Bootloader über ISP funktioniert leider auch nicht aber wie mache ich dien "platt"?

Wie machst du das ?

Wenn du normale Sketche per ISP flashen kannst, geht auch der Bootloader.

Gute Frage?
Leider hat sich in den letzten paar Minuten die Ausgangslage verändert.
Ein Uno läuft jetzt wieder nach dem flashen.
bei den anderen beiden funktioniert danach nicht mal mehr das laden eines einfachen Sketches.

Hier noch die Fehlermeldung :

avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

Fehler beim Brennen des Bootloaders.

Ich vermute mal, du machst das alles über ein Steckbrett (Breadboard) oder diese einfachen Jumperkabel.

Damit hast du dann immer schlechten Kontakt.


alles "Originale"

bei den verbleibenden 2 UNO's ist der Atmega ein SMD und der andere ein ein DIL. Werde mal den grossen bestellen und dann schauen was passiert. Evtl. ist das ja das Problem.

Ich meinte die Verbindungen zwischen Programmer und Uno, nicht den Uno selber.

was für einen Programmer hast du?

Arduino ISP R3

Gundelputz:
Arduino ISP R3

Dann zeig doch bitte mal ein Foto von deinem Aufbau.

Ich benutze diese Anordnung (Arduino as ISP) schon sehr lange und habe nie Probleme.

Ich benutze diese Anordnung (Arduino as ISP) schon sehr lange und habe nie Probleme.

ich vermute mal, dass er nicht Arduino as ISP nutzt, sondern den hier:arduino-isp