Keyboard/Mouse freeze when uploading to Arduino Micro (Win 8)

I fixed it!

I am posting my solution to the problem, so that others can fix it themselves. I below the solution are some of my earlier updates to the thread, so feel free to compare your “symptoms” to see if this matches you.

-SOLUTION-

Go into the Arduino IDE. Click tools > Programmer > then USBtinyISP. Then upload.

This fixes the issue of the computer freezing when uploading to an Arduino Micro.

-UPDATES-

Update (2/17/14) - I have narrowed the problem down to the actual reset of the board. When the board is being programmed, the IDE resets the bootloader and checks for a new COM port to begin upload to. I know that this is the problem due to the fact that, even with the IDE closed, if the reset button is pressed while the Micro is even connected the the computer, the computer will instantly freeze. That’s why the freeze would occur during the actual upload. Additionally, as IDE 1.6.0 had just come out when I wrote this, installation of the new IDE has not resolved the issue…

Update (2/16/14) - I connected the micro, and went to serial monitor. As soon as the monitor opened, it would repeatedly show “TESTATA.” Every time this came up, the TX light on the micro would blink. Additionally, when I send gibberish to the Micro through the serial monitor, e.g. sending single letters, the RX light on the Micro would indicate that that the micro has received the “command.” So it seems as though the problem only occurs during upload. Screenshot of TESTATA command below…

–ORIGNAL THREAD–

Hi,

I am using an arduino micro with Windows 8.1 Professional, and the Arduino IDE.

I am using the example code “Blink” under “Basics.”

I connect the micro to the computer with a stadard USB micro connector, typically on COM 3 or 4. After editing the text of blink to reassign the digital write pin to pin 6 instead of 13, I upload the code. I have made sure that I have selected Arduino Micro from the board list under tools, and I have made sure that I have selected the right com port within the IDE.

This is where I begin to have problems. I select upload, and everything seems to be OK. The program compiles without a hitch, until the actual upload begins. When the IDE finally shows a status of “uploading,” my keyboard and trackpad freeze simultaneously. They can only be unfrozen with a hard restart (pressing the power button).

What I’ve tried:
-Checked all connections, ensured power draw was not overloading USB port
-Pressed and held reset button during compilation, and then released it after uploading began (as suggested under troubleshooting)
-I tried uploading a program to an Uno board; the process went without a hitch (no hang up)
-I have verified that the driver for the micro is installed (arduino.inf)
-I have verified that the Logitech Process Service is nonexistent (I use a windows wireless mouse)

Any help would be absolutely appreciated. I have attached screenshots of the driver for the Micro, as well as where it appears in device manager.

Thanks!
-Connor

Full text of Blink (with edit):

void setup() {       
pinMode(6, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(6, HIGH);   
  delay(1000);              
  digitalWrite(6, LOW);    
  delay(1000);              
}

Screenshot (46).png

Screenshot (47).png