Killed my ATmega?

I was playing around with the project at http://openenergymonitor.org

I created the circuits (with larger capacitors 50uF) detailed on this page for the current transformer and the wall wart: http://openenergymonitor.org/emon/node/59

I am attached to A3, A4, 5v, and gnd.

Everything appeared to be ok (other than some values appeared as negative), but then I removed the USB from the arduino (which was it’s power source) and it stayed on. I then removed the +5V line from the arduino and it still stayed on. Then I removed the ground (I may have plugged the 5v line in, not sure) and the on LED dimmed, but still stayed on.
I am not sure what the impact of these actions is, but it appears I bricked my Arduino and unfortnuately it is an Uno which probably means the whole thing is toast.

Symptoms:

  • 0n LED is lit
  • “Loop-Back Test” is successful
  • not appear to be running the program
  • attempting to upload a sketch results in “avrdude: stk500_recv(): programmer is not responding.”

Now it is time for the autopsy and understanding what happened as to prevent it from happening again. I am guessing the current transformer, but more probably the 9VAC wall wart kept powering the ardino. Maybe I fried it when I removed the ground or the 5v and the positive had to flow through the analog pin. Possibly just when

Can anyone provide confirmation, other hypothesizes, or better yet a fix?

chaseadam: I created the circuits (with larger capacitors 50uF) detailed on this page for the current transformer and the wall wart: http://openenergymonitor.org/emon/node/59o

My browser says: "The requested page could not be found."

Typo in URL. Fixed above.

DC Voltage potential between analog pins and 5V line:

A0: 1V - 2V A1: 1.7V A2: 1V - 2V A3: 1.7V A4: 5V A5: 1.7V

Looks like I blew through A4? Not sure if this is normal, probably not.

Seems I may have hooked up the circuit incorrectly as I cannot reproduce after dis-assembly and re-assembling. I doubt the "phantom" on behavior has to do with whether the microprocessor is actually running or not.

Still looking for confirmation or suggestions. Does A4 being shorted to ground definitively indicate busted ATmega?

Definitely not normal. If you can’t load a sketch on it, it’s effectively dead. You can try loading it differently using a programmer, maybe the 8U2 is fried. You should limit the size of the capacitor to 10uf max, larger will filter the incoming voltage too much and throw your reading off. For that part of the circuit I used a 4.7uf.

When I was bringing mine up I used the USB port exclusively for powering the arduino. That way I could pull a single plug and disconnect all power. I also worked up the CT and voltage measuring circuits BEFORE I hooked it to an arduino input pin. When I had the divider resistors selected to give me around 1VAC on the meter I felt safe enough to hook it to the analog pin on the arduino. My initial test load was a 1500 watt toaster so I cold flip the lever and turn it off easily. Had a lot of leftover toast for breadcrumbs.

sorry

I couldn’t find a good resource for detailing the removal of the SMD 8u2. I tried a hair dryer with a funnel and that was unsuccessful. I was successful with a pair of soldering irons, patience, and some solder to help distribute the heat from the irons to surround the chip. The trick is that there is a ground plate under the chip which also needs to melt. During the cleanup process I ripped off two pads which are unused by arduino (I believe they are ADC6/7). I ordered a TQFP which is much easier to work with and it pin compatible as a replacement.

I also ordered a DIP-based Uno so I don’t have to worry about this in the future.