Killed Yun?

Hello,

a couple of weeks ago I got an Arduino Yun and got it quickly working. To pair a highly customizable Linux with a realtime processor is really appealing!

I did some sketches involving an RGB sensor and a Adafruit Neopixel 8x8 Matrix. All worked well until I wanted to try some kind of light logger to SD-Card. These are the symptoms I observed:

  • Yun doesn't connect as a keyboard anymore (connected Yun with an USB cable)
  • No I2C device seems to get recognized, i.E. the tcs.begin() (see below) does'nt return at all
  • Communication through Wifi and USB works, uploading sketches work too
  • Simple blink sketch works too
  • Simple logger sketch does not work but that might be me adressing the file in the wrong place -- I placed an "arduino" folder in the root of the SD-Card, chmod' it to 777 and tried both relative and absolute path names
  • Sensors are OK, I got them working on another Arduino
  • Sketch is also ok, as far as I could try it out on another Arduino (removed all Bridge/Filesystem calls and replaced Console with Serial)

Is there anything more I could do to narrow down/solve the problem? May I have killed the Yun? How? During experimenting with the RGB matrix I used a 2A power supply and kept the brightness of the Matrix to 40 (from 255), so, the maximum current (of about 4 A) shouldn't have been a problem. I did provide all the power through the Yun, however... Since I live in northern Norway, it was difficult to get a Yun in the first place.

Greetings from the snowy Tromsø,

Frank

Adafruit_TCS34725 tcs = Adafruit_TCS34725();
void setup(void) {
  if (!tcs.begin()) {
...
  }
}

Hello, seems the problem was solved (more or less) by itself. For whatever reason, tcs.setInterrupt(true) before tcs.begin() interfered somehow with the remaining sketch. My yun still does not connect as a keyboard/mouse anymore, but that's not my concern since I didn't plan to use that feature anyway.

Greetings from Tromsø, Frank