"L" LED doesn't blink

Hi, I just got my arduino starter kit today (arduino UNO) and tried the blink sketch. it seems that the L LED doesn't blink when I run sketch, it just stays lit. I've tested connecting an LED to pin 13 and the LED does blink, which means the sketch is running correctly.

2 Questions: 1. Could it be possible that my arduino is faulty? 2. Is this something that I can live without? I'm just new but I'm guessing this will be used a lot in debugging.

  1. There’s always a change but it’s very small.
  2. Also but I don’t think the board is faulty. I suspect pure PEBCAK :wink:

Is it a real Arduino or a clone (from eBay, AliExpress, Alibaba, Amazon)

Does the IDE tell you the upload is successful?

I'm pretty sure it's real, I got it from amazon, it has 500+ reviews.

Yes the IDE says the upload is successful, I even tried changing the delay, it affected the LED that I connected.

I also tried the spaceship interface project that came with the project book (simple circuit and basic code), it works , so I know that the uploading works.

I have a short video https://www.youtube.com/watch?v=COJaFLUHEbs

Could be a problem with opamp U5B, which buffers D13 and drives the onboard LED. https://www.arduino.cc/en/uploads/Main/Arduino_Uno_Rev3-schematic.pdf