l293e

Buonasera a tutti! Per far muovere il mio stepper bipolare ho optato per un l293. Il mio negozio di fiducia aveva però solo gli l293e, e, pensando che non cambiasse niente, ne ho preso uno. A casa ho provato mettendo high gli ingressi e ponendo dei led agli output e noto che si accendono tutti... non ci dovrebbe essere un uscita negativa e una positiva per i bipolari? Grazie per l'aiuto.

--->Allego datasheet

Ho trovato un topic del vecchio forum --> http://forum.arduino.cc/index.php/topic,1883.0.html La differenza è l'aggiunta del pin SENSE. come si usi non ne ho idea. :sweat_smile:

I pin SENSE servono per misurare la corrente dei motori. Per quello colleghi tra SENSe e massa una piccola resistenza. Se non vuoi misurare la corrente puoi collegare i pin SENSE direttamente a massa. Il L293E a differenza del L293D non ha diodi di protezione. Devi metterli Tu. 2 per ogni uscita (8 in tutto). http://static.electro-tech-online.com/imgcache/633-l293e.jpg http://robotics.home.sapo.pt/l293e.gif

Ciao Uwe

grazie a entrambi per la risposta. bene,metterò i diodi e collegherò i sense a massa. per il fatto che invece dà fuori solo +5V e mai gnd quale può essere la soluzione? è impostato male? sono io che sbaglio e non ci de ve essere nessun gnd? domani provo comunque a fare un' altra prova, per sicurezza. grazie anfora a Paolo e Uwe XD buonotte a tutti!

Se non avevi collegato SENSE a massa non poteva tirare l' uscita a massa. lo vedi nell'immagine sotostante Ciao Uwe

Giusto. Tra un po' riprovo e vi so dire :)