L298N Enable Pin

Post another image of your new wiring.

just makes zz sound. But engine doesn't turn or work.

Also give details of the battery. It's not shown in the image, or discussed in detail.

Have you monitored the voltage on the enable line when its being activated - is it reaching what you expect?

Sorry. I filled my maximum answer capacity, I can reply again now. 12V alkaline orion battery.

(I did not connect a power supply for testing purposes, I am testing it by hand)

Connection must be correct. If you see any wrong please tell me

I will measure again when I take my multimeter back. I will let you know

try to connect the + 5V terminal of the L298 module to the + 5V pin of the Arduino. and then test that the engine is now running.
Have you ever tested whether the engine runs when you connect it directly to the battery? The battery you are using is not actually intended to power motors, it has enough voltage but not enough power. At least it won't last very long, but it should be enough for short tests if the engine is running at all.

1 Like

I connected as you say, and same just zz sound. Yes I tested engine works well. I also changed the battery,when it is connected to the arduino, engine still makes zz sound.

He/she said several things, so which connection are you referring to?

It sounds like, you didn't try connecting the motor directly to the battery, without any Arduino in the circuit. That is an important experiment.

I can tell you this much, the battery is pathetically small to be running any motor.

I measured.
Out 3 0,65V
Out 4 0,4V
In 4 -0,01V
In 3 4,8V
En 1.9V(should be min 2,3V)

**try connecting the motor directly to the battery !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
**

Did I say, "try connecting the motor directly to the battery"

Also please explain, why you "expect" 1.9V on the enable line...

Sorry, I checked datasheet again I need min 2,3 V and I measure 1.9V, its not expected. Yes I tested to connect directly battery, it works completely well. So, I must solve why it takes 1.9V

You never posted a complete sketch.

can you explain what do you mean by saying complete sketch, I am newbie sorry, I must learn

All of the sketch, not just parts of it

Guys Thanks for everything. I don't know how but I used my friend's arduino and motor works there then I connected mines, It works on it as well. That was weird, motor works well for now. I just changed the cards and it fixed magically.

Thanks for the feedback.
Maybe a contact problem after all.
I recently wanted to replace the external EEPROM on the motherboard for a 3D printer (the 32-bit processor of this board has no internal EEPROM, just an emulated one) with a FRAM module from Adafruit. But the module was not recognized despite the same I2C address and did not allow access. So I added an I2C EEPORM module again, which worked before.
Well, about 2 weeks ago I wanted to connect the FRAM module to an Arduino Uno, because the I needed more space for graphics and text than there is in the internal EEPROM (the FRAM module offers 32K, the internal EEPROM only 2K, me Required approx. 6K) Then the following happened: FRAM module did not keep the written data! I couldn't explain it to myself, everything was plugged in correctly and all cables looked perfect. So I ran the I2C address scanner. See there: No FRAM found. then I measured all connections on the module and to the module. Result: SDA line has no electrical connection. Then I examined it more closely, and in fact one of the two plugs on the cable (it was also a 'breadboard cable', no electrical connection to the conductor in the cable. By the way, the cable was brand new when I attached it).
After replacing the cable, the FRAM module works as expected and it now also runs on the motherboard of the 3D printer.

1 Like

Electronics is really weird :smiley: . I hope you do better works in the future! I hope we do both!