Language reference improvement

In the language reference min, max, constrain and abs are described as functions but they are macros. It is mentioned (regarding max, min, abs) that you should avoid maths inside the call. But I think it would be best to describe explicit that they are in fact macros. I'm not the first (an probably not the last) to have been confused by this difference.

Definitely not the first, we had a large discussion about it 3 years ago: http://forum.arduino.cc/index.php?topic=84364.0.

You could add an issue here: https://github.com/arduino/Arduino/issues and you may have some luck getting the reference changed to describe macros rather than functions.

Ok. But in the reference there is a link to here to suggest improvements...