Launch4j  "An error occurred while starting the a

NEWBIE Q, What does Ardunio.exe need on startup? Symtom: Double click on arduino.exe, long pause, then Launch4j gives an error "An error occurred while starting the application", then it dies.

I tried: * Windows XP SP3 Notebook (2.0ghz P4) * Windows XP SP2 desktop. (2.4ghz Celleron) * uninstalled the JAVA that was already installed on my notebook. * tried safe mode. * I tried using administrator. * tried version 0022 & 0021 (and removed parameters.txt) * There is no "run.bat" in either release (mentioned in FAQ). * Disabled all com ports except arduino * msconfig diagnostic startup. (and a couple of variants) * tried deleting parameters.txt (several cases above) * Two devices installed (USB Serial Port(COM4) and USB Serial Converter. * Extract of ZIP file was clean on both computers. * PWR led is on, Blinking led is blinking. * Arduino Duemilanove (usb) * arduino directory has a file launch4j.txt:

CmdLine: C:\Documents and Settings\user\Desktop\arduino\arduino-0022\arduino.exe --l4j-debug WOW64: no Working dir: C:\Documents and Settings\user\Desktop\arduino\arduino-0022. Bundled JRE: java Check launcher: C:\Documents and Settings\user\Desktop\arduino\arduino-0022\java\bin\javaw.exe (OK) Add classpath: lib\pde.jar Add classpath: lib\core.jar Add classpath: lib\jna.jar Add classpath: lib\ecj.jar Add classpath: lib\RXTXcomm.jar Launcher: C:\Documents and Settings\user\Desktop\arduino\arduino-0022\java\bin\javaw.exe Launcher args: -Xms128m -Xmx128m -classpath "lib;C:\Documents and Settings\user\Desktop\arduino\arduino-0022\java\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" Args length: 199/32768 chars

This is an interesting problem and quite a few people apparently have it but I have not found any solutions.

Anyone have suggestions on other things I can try?

I am going to bring up a vanilla XP SP2 once I find a box that can run it.

Thanks for any ideas you may have... Tim

NEWBIE to Arduino, used mc68hc705 and MSP430..

Are you using the same download?

No matter what it says about the file, I remember someone else having this issue and a re-download of the file seemed to fix it.

I have had that error occasionally but I can't pin down why. I got it when loading 0021 off my memory stick but it worked, just took a while and gave me the error on startup.


Thanks for looking at my problem. In a sense I have downloaded twice. I downloaded 0022 then I tried 0021 (erasing the parameters.txt each time).

I just took a brand new PC out of the BOX at work today and I tried it there, no network or anything, XP SP3 and 0022 worked. So now I know there is some sort of system requirement I am missing. A System Requirement can be some sort of hardware OR software requirement.

Since I can not take this computer home I still NEED to figure out what Requirement Ardunio.exe has. So far I see that Arduino.exe has a requirement for a specfic Java since they included the Java in the package. So I bet there is some sort of other problem. I also see TCL/TK and Cygwin. Both my home computers have Itunes to be able to sync my Iphone and that uses USB. One of my computers has Cygwin but not the other. Not sure how I am going to do this without acquiring another computer and adding all my stuff one at a time till I bump into the Requirement that is incompatible with Arduino.exe. I wish the developers had listed all the things that are used/required by arduino.exe.

If anyone has more suggestions I welcome them.

Thanks very much for your help!


I will keep this in mind and if I remember anything/come across anything then I will let you know.


SOLUTION: Use windows ZIP instead of WINZIP. Some sort of problem right at the end of the unzip, it has a long pause at the end. Everything looked ok but it wasn't.


Weird, windows zip software is rubbish ;)

I used WinZIP with no issues on most of my installs.