launch4j error, tried many things, nothing works

Hello, yesterday I started arduino.exe, after about 1-2 minutes I got the error launch4j. I use Windows 7 Professional 64bit.

I updated my Java Runtime Environment, renamed the data folder, reinstalled it, installed the beta-version, nothing helped.

When I start arduino with arduino.exe --l4j-debug I get this in the text-file:

CmdLine: C:\Users\David\Desktop\Arduino\arduino.exe --l4j-debug WOW64: yes Working dir: C:\Users\David\Desktop\Arduino. Bundled JRE: java Check launcher: C:\Users\David\Desktop\Arduino\java\bin\javaw.exe (n/a) 64-bit search: SOFTWARE\JavaSoft\Java Runtime Environment... 32-bit search: SOFTWARE\JavaSoft\Java Runtime Environment... Match: SOFTWARE\JavaSoft\Java Runtime Environment\1.8 Match: SOFTWARE\JavaSoft\Java Runtime Environment\1.8.0_11 64-bit search: SOFTWARE\JavaSoft\Java Development Kit... 32-bit search: SOFTWARE\JavaSoft\Java Development Kit... Ignore: SOFTWARE\JavaSoft\Java Development Kit\1.8 Ignore: SOFTWARE\JavaSoft\Java Development Kit\1.8.0_11 Check launcher: C:\Program Files (x86)\Java\jre8\bin\javaw.exe (OK) Add classpath: lib\pde.jar Add classpath: lib\core.jar Add classpath: lib\jna.jar Add classpath: lib\ecj.jar Add classpath: lib\RXTXcomm.jar Launcher: C:\Program Files (x86)\Java\jre8\bin\javaw.exe Launcher args: -Xms128m -Xmx128m -classpath "lib;C:\Program Files (x86)\Java\jre8\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base Args length: 167/32768 chars

Could you help me please? Tomorrow I have to bring in a programm for a little roboter, but now it looks like I cannot meet the deadline.

Thanks for your help

tiffyweh

edit: by renaming the data folder i meant renaming the whole folder in which arduino is installed. I also tried renaming the arduino.exe.

I just got this problem too. Coincidence ? Something windows update did, or something

I will try to undo the last Windows Update. Maybe any other suggestions?