LCD an Arduino Nano wie anschließen

Hallo.

Ich hatte folgendes Projekt bei mir auch installiert, auf einem Uno. Klick
Der Uno hat nach einem halben Jahr Dauerbetrieb plötzlich den Geist aufgegeben, ich habe mir nun einen Nano heute gekauft.

Den Code habe ich vom Projekt einfach übernommen und geringfügig angepasst:

LiquidCrystal lcd(7,6,5,4,3,2);

Am Uno war das ja selbsterklärend, aber wo stecke ich diese Pins nun am Nano ein? An die D oder an die A Pin´s? Kann ich das überhaupt so 1 zu 1 übernehmen und machen?

Wäre cool, wenn mir jemand helfen könnte, bevor ich was kaputt mache :slight_smile:

Danke schon mal

D(igital) pins

Der Nano ist eine 1 zu 1 Kopie des Arduino 2009. Der UNO hat 3 pins mehr (I2C nochmal herausgeführt und ein Spannungsversorgungspin), Die LED an pin 13 durch einen Operationsverstärker entkoppelt und einen anderen USB Adapter. Er aht auch einen kleineren aber in der Übertragung schnelleren Bootloader

Grüße Uwe

Aber die Pin-Bezeichnungen sind doch zum Uno identisch. Beispiel (D1, D2, D3 usw., A0, A1, usw.)

Bei dem Display musst du die mit D=digital gekennzeichneten Pins verwenden.

Also beim Uno gab Analog Eingänge A0 A1 usw... und Digitaleingänge, die 1-13 benannut sind. 3 5 6 10 und 11 hatten eine ~davor.

Habe es nun an den Nano an die D Pins angeschlossen, geht leider nicht, das Display zeigt erst 2 weiße Balken an, danach bleibt es leer. Die RX Led blinkt allerdings im Sekundentakt, das ist so das Intervall, wo ein Singnal rein kommt. Das scheint also zu funktionieren... aber das Display bleibt dunkel :frowning:

Dann zeige zur Sicherheit mal alle Infos an, damit wir nicht rätseln müssen:

  1. die elektrischen Verbindungen zwischen Nano und LCD
  2. deinen sketch

Irgendwo muss ja der Wurm drin sein.

Meistens bei LCD-Displays sind es folgende Dine:

  • Lötverbindungen (falsch oder schlecht)
  • Konstruktor passt nicht zur verwendeten library
  • Kontrastregler
  • fehlende / falsch angeschlossene Stromversorgung des Displays

rpt007:

  • Kontrastregler

Der war schuld. Habe ihn ein paar mal hin und her bewegt, nun zeigt das LCD wieder an. Bin gerade selbst drauf gekommen :smiley:

Trotzdem Dankeschön :slight_smile: