LCD EXIT STATUS 1 REDEFINITION OF 'VOID SETP ()'

The code isn’t working to display text on my lcd screen. I’m running a Arduino elegoo UNO 3 on arduino 1.8.1. My code is included in the post. I can’t figure out why it isn’t working. I have the programmer under AVRISP mkll and i’ve enabled my com 3 port. Any help would be greatly appreciated.

// include the library code:
#include <LiquidCrystal.h>

// initialize the library with the numbers of the interface pins
LiquidCrystal lcd(7, 8, 9, 10, 11, 12);

void setup() {
// set up the LCD’s number of columns and rows:
lcd.begin(16, 2);
// Print a message to the LCD.
lcd.print(“hello, world!”);
}

void loop() {
// set the cursor to column 0, line 1
// (note: line 1 is the second row, since counting begins with 0):
lcd.setCursor(0, 1);
// print the number of seconds since reset:
lcd.print(millis() / 1000);
}

What's not working?

.

Arduino: 1.8.1 (Windows 8.1), Board: "Arduino/Genuino Uno"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Michael\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0001 -ide-version=10801 -build-path C:\Users\Michael\AppData\Local\Temp\arduino_build_238951 -warnings=none -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Michael\Desktop\sketch_mar17c\sketch_mar17c.ino C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Michael\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0001 -ide-version=10801 -build-path C:\Users\Michael\AppData\Local\Temp\arduino_build_238951 -warnings=none -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Michael\Desktop\sketch_mar17c\sketch_mar17c.ino Using board 'uno' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr Using core 'arduino' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr Detecting libraries used... "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10801 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\Michael\AppData\Local\Temp\arduino_build_238951\sketch\sketch_mar17c.ino.cpp" -o "nul" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10801 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard" "-IC:\Program Files (x86)\Arduino\libraries\LiquidCrystal\src" "C:\Users\Michael\AppData\Local\Temp\arduino_build_238951\sketch\sketch_mar17c.ino.cpp" -o "nul" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10801 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard" "-IC:\Program Files (x86)\Arduino\libraries\LiquidCrystal\src" "C:\Program Files (x86)\Arduino\libraries\LiquidCrystal\src\LiquidCrystal.cpp" -o "nul" Generating function prototypes... "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10801 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard" "-IC:\Program Files (x86)\Arduino\libraries\LiquidCrystal\src" "C:\Users\Michael\AppData\Local\Temp\arduino_build_238951\sketch\sketch_mar17c.ino.cpp" -o "C:\Users\Michael\AppData\Local\Temp\arduino_build_238951\preproc\ctags_target_for_gcc_minus_e.cpp" "C:\Program Files (x86)\Arduino\tools-builder\ctags\5.8-arduino11/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\Users\Michael\AppData\Local\Temp\arduino_build_238951\preproc\ctags_target_for_gcc_minus_e.cpp" Compiling sketch... "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10801 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard" "-IC:\Program Files (x86)\Arduino\libraries\LiquidCrystal\src" "C:\Users\Michael\AppData\Local\Temp\arduino_build_238951\sketch\sketch_mar17c.ino.cpp" -o "C:\Users\Michael\AppData\Local\Temp\arduino_build_238951\sketch\sketch_mar17c.ino.cpp.o" C:\Users\Michael\Desktop\sketch_mar17c\Display.ino: In function 'void setup()':

Display:45: error: redefinition of 'void setup()'

void setup() {

^

C:\Users\Michael\Desktop\sketch_mar17c\sketch_mar17c.ino:1:6: note: 'void setup()' previously defined here

void setup() {

^

C:\Users\Michael\Desktop\sketch_mar17c\Display.ino: In function 'void loop()':

Display:52: error: redefinition of 'void loop()'

void loop() {

^

C:\Users\Michael\Desktop\sketch_mar17c\sketch_mar17c.ino:6:6: note: 'void loop()' previously defined here

void loop() {

^

C:\Users\Michael\Desktop\sketch_mar17c\HelloWorld.ino: At global scope:

HelloWorld:46: error: redefinition of 'LiquidCrystal lcd'

LiquidCrystal lcd(7, 8, 9, 10, 11, 12);

^

C:\Users\Michael\Desktop\sketch_mar17c\Display.ino:43:15: note: 'LiquidCrystal lcd' previously declared here

LiquidCrystal lcd(7,8,9,10,11,12);

^

C:\Users\Michael\Desktop\sketch_mar17c\HelloWorld.ino: In function 'void setup()':

HelloWorld:48: error: redefinition of 'void setup()'

void setup() {

^

C:\Users\Michael\Desktop\sketch_mar17c\sketch_mar17c.ino:1:6: note: 'void setup()' previously defined here

void setup() {

^

C:\Users\Michael\Desktop\sketch_mar17c\HelloWorld.ino: In function 'void loop()':

HelloWorld:55: error: redefinition of 'void loop()'

void loop() {

^

C:\Users\Michael\Desktop\sketch_mar17c\sketch_mar17c.ino:6:6: note: 'void loop()' previously defined here

void loop() {

^

Using library LiquidCrystal at version 1.0.5 in folder: C:\Program Files (x86)\Arduino\libraries\LiquidCrystal exit status 1 redefinition of 'void setup()'

It looks like you have more than one .ino file in your sketch directory. --- bill

It is pointless to talk about code that won't even compile as "not working". YOU did something wrong. Not the compiler. Not the IDE. Not the Arduino.