LCD illisisibles characters

Hello,

When my serial port (9600) which also works well, starts up, my LCD (QC2004A) receives illisisibles characters. It takes 2 to 3 times "reset" Arduino Mega 2560 as playable characters appear on the LCD. How refers me?

Toshiba Sat P200 win32-win7 - 9600

Best Regards Georges

Hi Georges97427.

Your post is very hard to read (understand), seems to be translated using some program. You told about your Mega 2560 that, if the comport is active, doesn't show characters you can read, right ? What comport would that be, as the Mega has 4 hardware ports. And can you tell us how you connected the display to the Mega ?

Perhaps you have used pins 0 and 1 and/or pins 14 - 21 to connect your display. If so, use other pins for that display, or make sure the comport connected to those pins is disabled.

MAS3,

Ich spreche Deutsch, Français....no english!! sorry!

Then it probably would be better to ask your questions in the corresponding forums.

Oder: Wäre es nicht besser deine Fragen im Deutschen Forum zu stellen ? Französisch geht mir nicht so gut ab.

Also nochmals, hast Du deinen Display mit irgend einen Pin verbunden, der auch für die serielle Schnittstelle benutzt wird ? In dem Fall, benutze ein anderer Pin, und passe dein Sketch dementsprechend an.

Zum 1. auf den englischen Foren bekommt man mehr Nachrichten.

  1. Nein ich habe nur allgemeine pins belegt und zwar: A0, A9, A11, A12, 5, 42 bis 48

Ich benütze editor arduino 1.6.1

Also wen ich auf das Ikon "Monitor Seriel" drücke, kurz danachach kommt das Bild und dan werden werden wilkürliche Zeichen auf dem LCD angezeigt. So muss ich 3 bis 4 mal resetieren auf der 2560 Platine. Irgendwie scheint das timing nicht zu stimmen. Ich habe die Baudrat auf 19200 eingestellen aber dan kommen willkürliche Zeichen auf dem Seriellen monitor.

Can you show a picture of your setup, showing how Mega and display are connected, and perhaps showing the problem ?

Do you have anything else connected to the Mega besides the display and the serial connection to the PC (probably through the USB connector) ?

German:

Kannst Du uns ein Foto zeigen wo zu sehen ist wie die teile verbunden sind, und vielleicht auch das Problem am Display zeigt ?

Gibt es auch noch andere Sachen die am Mega verbunden sind, neben das Display und der PC (wahrscheinlich über die USB Schnittstelle).

This is the English forum. Post in English or I will move it.

sorry Nick !! Ok for German Forum.

[quote author=Nick Gammon link=msg=2173846 date=1428280040] This is the English forum. Post in English or I will move it. [/quote]

Hä? Hab ich was verpasst?

Gruß Chris

Nochmal Arduino edit ist die 1.6.1 version . bei starten des sketchs sind die zahlen auf dem LCD lesbarr, drücke ich auf Monitor serial dann geht das Fenster auf und die Daten sind lesbar aber gleichzeitig werden die Daten auf LCD unlesbar So muss ich 3 bis 4 mal auf die Reset Taste drücken vo Mega 2560.

Also hier Bilder, sorry für verkabelung, bin noch nicht fertig. Danke für die Antwort. Uns sorry für mein englisch. Georges

vergessen…

Georges97427: MAS3,

Ich spreche Deutsch, Français....no english!! sorry!

Das sit schon kuros. Du stellst eine Frage auf Englisch im englischen Forum und verstehst dann nicht genug Englisch um die Antwort zu verstehen.

Wenn Du meinst, daß Du mehr und bessere Antworten im englischen Forum bekommst, dann lerne englisch.

1) wieso nimmst du nicht die Hardwareschnittstellen des Arduino Mega. Er hat 3 unbenutzte. 2) Die Baudrate des Senders muß mit der des Emfängers Übereoinstimmen. 3) Gib und sen link wo du das Display gekauft hast 4) Gib uns den Sketch. Grüße Uwe

Ich habe die Fotos angeschaut.

Schließ zuerst mal das Display richtig an.

http://macherzin.net/article38-LC-Displays-am-Arduino

Grüße Uwe

Ok danke! werde mal nachsehen..

Wie soll deiner Spannungsversorgung zur Display funktionieren ? Was hast du da gebastelt mit dieser Lochplatine (nennt sich das so ?) mit LED und Kondensator/Widerstand ?

Uwe danke für die Nachricht aber das LCD ist korrekt geschaltet oder was meinst Du damit? Die Spannungsversorgung (ich hatte noch LM317) und ich will Strom messen so ist meine Gesamleistung nicht abhängig von Arduino. Die kleine Platine ist nur ein "Verteiler +,-) Das RC fliegt wieder heraus (versuchte eine Verzögerung). Ich werde das Arduino mega auswechseln, sehr günstig gekauft. Vermutet ...

Nochmals vielen Dank für euere Hilfe. werde mich nochmal melden.