LCD top row only showing blocks

I know this is a common problem and so I’m hoping its a simple fix.
my LCD is only showing blocks on the top row. I’ve had the program running perfect on this LCD and arduino before. I’v tried another LCD and the fault is the same so I know the LCD and Arduino are both fine. I tested each wire before connecting as I;m aware they can be dodgy. and my Live and neutrals are connected fine too. there has to be something I’m missing here.

Can you please upload your sketch?

You should insert a 220 ohm resistor in the line between 5V and pin marked 'A' (backlight led)

Your schematic and maybe your wiring is wrong. The R/W pin on the dislpay must be connected to GND and not to +5v. The +5v connection to the contrast potentiometer can be removed for easy contrast adjustment. /ffur

lcd pins.png
Expand!

ffur:
Your schematic and maybe your wiring is wrong. The R/W pin on the display must be connected to GND and not to +5v.

That will clearly be the problem. Just a little wiring blunder when you re-built it. :grinning:

ffur:
The +5v connection to the contrast potentiometer can be removed for easy contrast adjustment.

I am so glad people are getting the message about this longstanding error in the circuits mindlessly published. :sunglasses:

photoncatcher:
You should insert a 220 ohm resistor in the line between 5V and pin marked 'A' (backlight led)

Not if resistor "R8" already on the 1602 module is "101" or 100 Ohms, an additional resistor is quite unnecessary unless you wish to dim the backlight - and a 220 would not dim very much. That advice relates to some older displays which have not been very common for quite a while. :astonished:

Thank you all, the resistor as has been stated didn't work and only dimmed the LCD. i swapped the connections and I have a fully functioning LCD! 8)