LCD's weird malfunction

Hi everyone,

I am trying to use a Graphical LCD KS0108 under panel B configuration. When I hook up the LCD and run the example programs in the library folder of the GLCD, I get this error message " avrdude: stk500_getsync(): not in sync: resp=0x00" and I already know that it means there is a problem with my serial connection. I have tested my serial connection using other test programs and it works fine. I am sure that I have selected the correct port, correct Arduino model, reset the board before uploading and have checked the wiring, but I still get the same error message when run any of the examples in the GLCD library folder, i.e. "Hello World" etc.
I figured out that when I disconnect the power pins from the LCD the program uploads fine and serial connection takes place. I know this because one the examples in the GLCD library tested the serial and gave me this:

Reported Arduino Revision: 1.5

GLCD Lib Configuration: glcd ver: 3 glcd_Device ver: 1 gText ver: 1
GLCD Lib build date: Mon Dec 5 01:50:07 CST 2011
GLCD Lib build number: 442
Panel Configuration:ks0108
Pin Configuration:ks0108-Arduino

GLCD:ks0108 DisplayWidth:128 DisplayHeight:64
Chips:2 ChipWidth:64 ChipHeight:64
CSEL1:14(PIN_C0) CSEL2:15(PIN_C1)
RW:16(PIN_C2) DI:17(PIN_C3) EN:18(PIN_C4)
D0:8(PIN_B0) D1:9(PIN_B1) D2:10(PIN_B2) D3:11(PIN_B3)
D4:4(PIN_D4) D5:5(PIN_D5) D6:6(PIN_D6) D7:7(PIN_D7)
Delays: tDDR:320 tAS:140 tDSW:200 tWH:450 tWL:450
ChipSelects: CHIP0:(14,0x1, 15,0x0) CHIP1:(14,0x0, 15,0x1)
Data mode:
d0-d3:nibble mode-Non-Atomic
d4-d7:nibble mode-Non-Atomic
--------------------------------------Serial initialized

And this was after I had disconnected the power and uploaded the program again.
Any ideas what could be causing the problem?

What if you try to program the bare Arduino board, and connect hardware afterwards ?

I will try that and let you know. But remember that when I disconnected the power from LCD, the code uploaded with no error,but when I put the power back no signs of change were observed in the LCD. I will do what you say, but I am expecting the same outcome as when the power is not connected.

I think I just that my LCD is fried. It is highly likely. It is not working after the test either. But thanks for your help :slight_smile: