Led 13 (&embedded Led) flicking every 32 seconds

Dear Collegues,
I've just purchased my Arduino Uno Starter Kit, installed, connected everything and tested Example 01 flashing led 13.
It works OK until second 32, where the Led flicks for about a second, then carries on for another 32 seconds.
-I've changed ON time and OFF time but the problem still comes in second 32.
-I've changed flashing outpu to Output 12 & 8, with different time, but still does the same.

Any help on this?
Thank you in advance,
Joan Faig

That's odd, to say the least :slight_smile:

To be completely on the safe side, can you...

  1. Show us the code you uploaded? Maybe a picture of the circuit?
  2. Tell us exactly what are the symptoms - did you measure 32 seconds manually? What exactly did the LED do before and afterwards? ("then carries on" is not very clear - did it stay on continuously for 32 seconds?)

The code is just (comments deleted):
void setup()
{
pinMode(13, OUTPUT);
}

void loop()
{
digitalWrite(13, HIGH);
delay(1000); // Wait for one second
digitalWrite(13, LOW); // Turn off the LED
delay(1000); // Wait for one second
}
So it just flashes led 13 during one second, then stops for another second.
I've counted manually the seconds and in second 32, the inner (and outer led) blink several times for maybe less than a second, then keeps on flashing for one second and stopping the next.

Another thing I've tried is to use a 9V battery instead of the USB. I works OK! No blinking!
When I reconnect the USB cable, it still works until I press the reset button, and starts flicking again.

Hope this new info helps!
Yours,
Joan

Ah , the schematic is just:
Output 13->YELLOW LED->330 Ohm resistor->GND (- in board)

It sounds as if there's an unwanted Reset of the Arduino after 32 seconds.
What happens if you change both delays to, say, 500 and upload the code? Does the LED go on/off each half second? and does the problem appear after 32 seconds or after 16?

The code blinks steady and continuously on my UNO, So as suspected it is not the code. And as you say on hard power (non-USB) yours blinks steady so it is not the UNO.

As you notice when you upload a sketch from the IDE the light blinks a few fast flashes for the reset from the DTR or software.
What may be a suspect is your PC is at 32 second intervals scanning the USB port which is acting like the upload trigger.

Try uploading the "Bare Minimum" sketch and see if you see any 32 second interval blinks after the sketch is loaded.

igendel: Indeed it seems an unwanted reset.
When changing the delay time to 500ms, it flashes half a second and stops half a second, but blinks still after 32 seconds. Tested with 2000ms also and still blinks quickly at 32 seconds.

spicetraders: Just tried the 'bare minimum' as you said, and it still gives the problem.
It does nothing for 32 seconds, then led (internal and external) flash quickly for half a second.
Gives consistency to the 'reset idea', doesn't it?

Now what?
Joan

Some program has a USB interface running in the back ground. Likely, this is being loaded automatically. Could be a print driver, scanner driver, etc. Good luck!

On Windows, you can clean-boot without anything non-critical being loaded.
Google : ‘Clean boot Windows’

Yes, I’m afraid there’s some unrelated process running on your computer that’s causing this issue.
See, for example, this:

I have stopped my Sony Companion software (active in background) and it doesn't reset anymore after those 30-32 seconds.
Haven't used external LED, but internal does what it should.
PROBLEM SOLVED!
Thank you all!
Regards,
Joan

jfaig:
I have stopped my Sony Companion software (active in background) and it doesn't reset anymore

Wow, the exact same software as in the link I found by chance!
Glad that's solved, now you can move on to bugs of your own ;D