LED13 Flashing all the time

I recently got a Freeduino v1.16 and it worked fine for a week. I was trying out some code to play sound samples (http://www.arduino.cc/playground/Code/PCMAudio) but after uploading my own sound one time it didn't play. After that I noticed that LED 13 was just flashing continuously.

I reset the Freeduino, and as soon as the reset is released, the LED flashes. I can't connect to flash a new program. I guess I've corrupted the Bootloader somehow or broken the ATMega168. Is there any way of testing if the chip is broken?

In the interim I built a Parallel Port programmer (http://www.arduino.cc/en/Hacking/ParallelProgrammer) and I've tried to read the fuses but it just returns 0xFF so I think I've built it wrong, or the chip is broken, or using UISP wrong.

Now I'm reading it might not be a good programmer anyway http://www.dl1dow.de/inhalt/arduino/bootloader/index.html

So, any ideas what is wrong with my Freeduino? And how to fix it?

After 3 days of turning it on, trying to connect my own parallel programmer and trying to get some data out of the Freeduino, I've managed to fix it.

The solution (for me) had nothing to do with using Parallel ISP but by watching the LED. I assumed that when I plugged the board into my USB, the LED would start flashing immediately but tonight I noticed that it flashed slowly for 5 seconds or so, then quickly. Having read the source for the bootloader I realised that it has a pause before running the main sketch. In this gap between plugging in the USB and the sketch running I managed to upload the blink sketch.

I'm guessing that I'd been using the reset button to try to reset the Freeduino and hadn't noticed the delay before now after I first power up the Freeduino.

I think this delay is a great idea. I wonder if a jumper on the ISP connection might also be used to tell the bootloader to not run a sketch on reset and just to wait for new code. This would also have helped me overwrite the harmful sketch.