LedControl Library problem with Teensy in thr Teensyduino IDE

Hello,

the example code used:

#include <LedControl.h>

void setup() {
LedControl.startBlink(9,1000,500);
LedControl.startBlink(8,200);
}

void loop() {
LedControl.loop();
}

The compilation errors:

“C:\Program Files (x86)\Arduino\hardware\teensy/…/tools/arm/bin/arm-none-eabi-g++” -c -O -g -Wall -ffunction-sections -fdata-sections -nostdlib -MMD -fno-exceptions -felide-constructors -std=gnu++0x -fno-rtti -mthumb -mcpu=cortex-m4 -fsingle-precision-constant -D__MK20DX256__ -DTEENSYDUINO=129 -DARDUINO=10609 -DF_CPU=96000000 -DUSB_SERIAL -DLAYOUT_US_ENGLISH “-IC:\Program Files (x86)\Arduino\hardware\teensy\avr\cores\teensy3” “-IC:\Program Files (x86)\Arduino\hardware\teensy\avr\libraries\LedControl\src” “C:\Users\LKDA\AppData\Local\Temp\builda6f64d043470bb45719fdb7c59c08c5b.tmp\sketch\SimpleBlinker.ino.cpp” -o “C:\Users\LKDA\AppData\Local\Temp\builda6f64d043470bb45719fdb7c59c08c5b.tmp\sketch\SimpleBlinker.ino.cpp.o”
SimpleBlinker: In function ‘void setup()’:
SimpleBlinker:4: error: expected unqualified-id before ‘.’ token
LedControl.startBlink(9,1000,500);

^

SimpleBlinker:5: error: expected unqualified-id before ‘.’ token
LedControl.startBlink(8,200);

^

SimpleBlinker: In function ‘void loop()’:
SimpleBlinker:9: error: expected unqualified-id before ‘.’ token
LedControl.loop();

^

Utilisation de la bibliothèque LedControl version 1.0.6 dans le dossier: C:\Program Files (x86)\Arduino\hardware\teensy\avr\libraries\LedControl
expected unqualified-id before ‘.’ token

Please answer me to this bug

Thanks
Koffiluc

Hello,

I fixed the errors. I have removed the librairies files ledControl.h and LedControl.cpp from the src folder and I have stored them at the same level than src folder.

Thanks Koffiluc