Leonard board dropping COM port on upload of sketch

I have recently purchased this board -Leonardo CAN BUS board

Running Windows 10

However when I try and upload any sketch, be it a custom sketch or the basic blink sketch i receive and error message telling me the com port can not be found.

I have tried on a Windows desktop, Laptop and Mac laptop, updated drivers manually, tried several USB data cables and the same error each time.

My error message is - "Couldn't find a board on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board's reset button after initialisation"

This board does not have a reset button. I plug the board in to the computer and I get an alert to say the board is connected. The onboard LED starts flashing slowly. Looking at device manager I can see the new COM port, this is then selected in the Arduino IED along with the appropriate Leonardo board. Then when click upload sketch I hear the USB disconnect sound from the computer and the error message is displayed. The onboard LED then continuously flashes until the USB cable is removed.

Could this be a boot loader issue? Any other suggestions before I speak to the manufacturer?

If it does not have a reset button, it's not a Leonardo. You might have a ProMicro. Please post a link.

If so, you can short the reset pin to ground and release it again; do this when the IDE reports the memory usage.

Link in original post updated to now work. I am guessing it is a Leonardo style board as opposed to an exact copy.


I have been able to manually trigger the reset now using the pins shown in this picture. My board is on COM7 and I can watch in device manager along with an audio conformation, that the board disconnects and re-connects immediately when I trigger the reset.

The problem comes when uploading a sketch, it compiles, you hear the disconnection sound from the computer and then the onboard LED flashes continuously. No re-connection sound and an error message saying it can not find the COM port.

So for whatever reason when uploading a sketch the board wont re-connect.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.