Leonardo - avrdude: butterfly_recv(): programmer is not responding

Afternoon all,

I’m quite new to using Arduino, to drive WS2811 pixels. I’ve been using the Leonardo board for a number of weeks using the Fastled program. I have been increasing the number of pixels slowy over the last few weeks as the project I’m working on grows. This morning I connected the board to update the pixel count and the board freezes when uploading. I can see the board via the device manager, also I can retrieve the board info via the IDE drop menu. I tried resetting the board by holding down the button but nothing. I thought the board might be cooked (though it still works when not connected to via USB), so purchased a new board. I managed to upload the new sketch and noticed i didn’t seem to have the right number of pixels so reconnected the new board and bam same issue.

Operating system is windows 10.

Below is the error message i get

vrdude: Version 6.3-20190619
* Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/*
* Copyright (c) 2007-2014 Joerg Wunsch*
* System wide configuration file is “C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.42.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf”
_
Using Port : COM11*_
* Using Programmer : avr109*
* Overriding Baud Rate : 57600*
* AVR Part : ATmega32U4*
* Chip Erase delay : 9000 us*
* PAGEL : PD7*
* BS2 : PA0*
* RESET disposition : dedicated*
* RETRY pulse : SCK*
* serial program mode : yes*
* parallel program mode : yes*
* Timeout : 200*
* StabDelay : 100*
* CmdexeDelay : 25*
* SyncLoops : 32*
* ByteDelay : 0*
* PollIndex : 3*
* PollValue : 0x53*
* Memory Detail :*
* Block Poll Page Polled*
* Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack*
* ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------*
* eeprom 65 20 4 0 no 1024 4 0 9000 9000 0x00 0x00*
* flash 65 6 128 0 yes 32768 128 256 4500 4500 0x00 0x00*
* lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00*
* hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00*
* efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00*
* lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00*
* calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00*
* signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00*
* Programmer Type : butterfly*
* Description : Atmel AppNote AVR109 Boot Loader*
Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
Not sure where to start, any help would be most welcome.
kind regards
James

Try the suggestions here:

Hi Pert,

Thank you for the reply.

I've tried all those options, while googling yesterday and I still can't get it to load.