Leonardo doesn't appear in Port/Serial Ports (Mac OS Mojave)

Hi there,

I bought a Leonardo as I want to use an Arduino as a USB keyboard

I'm running it on Mac MacOS Mojave on a 2019 MacBook Pro.
In the IDE, I've elected the Leonardo as my board
if I go into Ports, the only thing I see is Serial Ports (greyed out) and /dev/cuBluetooth-Incomong-Port

I've tried installing the CH340 driver but I don't think that's for this board.

  • Is this fixable, if-so how?
  • If I get a Micro, will I run into a similar problem?
  • Info, is there another board I should get instead?

Thanks for your help!


I am using Leonardo too. I have a couple found in the following

1, While I was used old version IDS 1.6.X, the Leonardo board plugin, Comm port has no issue and the device manager show the Comm Port properly. Program by IDE working good. (sometimes found the Comm Port jumping back and fore from Comm 5 and comm 6)

2, In case I used the new version IDE instead of 1.8.X(Just plug in a new Leonardo board, the comm Port show okay), But Comm port might not be detected after programmed by this IDE(Caution). If you press the reset button on Leonardo, the comm Port might come back for a few seconds then disappeared. In case you use Keyboard.h library for some virtual keyboard application, it does not work. Just programming is Fine (no Serial Monitor and Serial Plot, since the Serial Port not established)

3, some people suggested modifying the power management USB part to avoid a reset. But I found it does not the matter. Also, I found the Device manager shows that USB (Device Descriptor Failed). It means you cannot use SAM D12 for the virtual USB to serial communication.

Conclusion: If you would like using the Leonardo board, I suggested you use the old IDE with a new Leonardo board. How to fix the Comm Port issues Leonardo board, Any folks who have idea please suggested!