Leonardo drivers for W7

Hi, first post here.

Just had my first Arduino, a Leonardo. Cant get the usb drivers on windows. I get the message 'windows was unable to install your arduino leonardo bootloader'

The device is listed in device manager under \ other devices \ arduino leonardo bootloader.

Hope you can help me get over this first hurdle

Tony

You should be able to install the driver for this device by pointing to the Arduino\Drivers folder.

Right click the device in Device Manager \ Other Devices Select Update Driver Software Select Browse my computer for software Click Browse button Select the Drivers folder under the location of your Arduino software installation Click OK Click Next

Thanks Louis

I can get to your Click OK step but windows says

windows was unable to install your arduino leonardo bootloader windows could not find driver software for your device

before I can get to Click Next step

I know I will look back in this with amusement when I work out what is wrong but right now its been four hours of frustration.

Tony

What version of the IDE do you have?
It needs to be 1.0.1: http://arduino.googlecode.com/files/arduino-1.0.1-windows.zip

Make sure you are selecting the Drivers folder(see attached image)

UpdateDriverSoftware.png

Yes version and method just like your instruction.

Device manager adds two devices that I can see when the Leonardo is connected.

Device Manager \ Other Devices \ arduino leonardo bootloader The drivers for this device are not installed. (Code 28) this has the yellow ! and is what I try to install drivers for.

Device Manager \ Human interface devices \ USB input device This device is working properly.

Tony

Open Device Manager Right Click the Device Manager \ Other Devices \ arduino leonardo bootloader Select Properties Select Details tab Choose Hardware Ids from the Property drop-down Send us the Hardware Ids that show in the Value section.

Hardware Ids

USB\VID_2341&PID_0034&REV_0100&MI_00 USB\VID_2341&PID_0034&MI_00

It looks like you must have an older version of the bootloader because the Arduino Leonardo.inf file is looking for: USB\VID_2341&PID_0036

It looks like Arduino IDE 1.0 has the Arduino Leonardo.inf that has that hardware ID.

Since I am not that familiar with the Leonardo, I am not sure the bootloader on your board is compatible with the 1.0.1 IDE.

I have seen mention in the forum that the Leonardo bootloader changed just before the official release.

Hopefully someone else can step in a clear this up.

Thanks Louis, you seem to have found my problem pretty fast, I was sure it was me doing something sooo stupid.

Not sure what the boot loader is, boot loader is initiated at run time from firmware maybe.

I have just been surfing and discovered there are different (clone) Leonardo on the market. I had mine from http://www.olimex.com/dev/olimexino-32u4.html

At the bottom of the above page it mentions

Latest BOOTLOADER for ARDUINO IDE 1.0.1

Thanks Tony

I down loaded 1.0.0 and the usb drivers are installed :grin:

Arduino Leonardo on com 3

No Leonardo in the board choice though so will put 1.0.1 back on and see what happens

So 1.0.1 back and tried to upload blink, failed a few times giving

avrdude: ser_send(): write error: sorry no info avail

So I guess I need to burn the updated boot loader, might need some direction on this.

Many thanks Tony

Bemused, if you're using an Olimex board, you should ask them for help. Unfortunately, we can't support other people's products (because we don't know how they work, etc).

Ok, just working out what I have done. Sorry I did not know the product was not yours.

Help here has been great so point me to a url to buy your Leonardo please.

Tony

We have a list of distributors here: http://arduino.cc/en/Main/Buy

For example, Adafruit in the US: http://www.adafruit.com/products/849

Or the Arduino store here: http://store.arduino.cc/ww/index.php?main_page=product_info&cPath=11_12&products_id=225 http://store.arduino.cc/ww/index.php?main_page=product_info&cPath=11_12&products_id=226

Ok so I just ordered an official Leonardo from one of your links, this will come with a 1.0.1 compatible bootloader I expect.

From this new standpoint I will be able to re-flash the the hooky Leonardo via the official working Leonardo?

Many thanks Tony

So I found the Leonardo board commented out in the c:\arduino-1.0\hardware\arduino\boards.txt” file

I removed the comments, Leonardo appeared in the boards menu and we are away having a little fun.

Tony

Hello, today is first day playing with a Leonardo. I am having the error shown in picture. http://imageshack.us/a/img191/3382/67934722.png I did search a lot on forums and follow the instructions there. Tried auto and manual driver install also. Tried rebooting, redownloading, reseting, reunzipping etc. Tried changing the port to com=>5. I just can't make it work. Pleaaase help.

Just got my Arduino Leonardo today from element14. and after connecting to my mac (running mac OS and windows7 OS), found out that i have the same problem with you guys. my Leonardo VID is not the same as the VID in leonardo inf file from Arduino 1.5. here is the screenshot of the 2 device the came out in my devmanager when i connect Leonardo:

and as expected i wont be able to install the driver completely.

but after some editing on the inf file, and updated the leonardo driver, the driver installed completely, uploaded blinking sketch,and blink the led without problem. (im not really sure though if it's really ok now, since i have a diff problem on serialevent sketch. XD XD XD )

here are the changes made: right inf file is the original inf file from Arduino 1.5. VID is not the same as my Leonardo VID left inf file is the edited inf file. i just change the VID and made it the same as my Leonardo VID

and after updating the driver of my Leonardo, driver installed successfully. but still, am having problem with SerialEvent sketch on Leonardo. XD XD XD

I concur I’m on a MBPro-Retina and I had to change the PID value in in the arduino.inf file to get my driver to install.
Thank you so much for the information!!

:slight_smile:
Roo

Hello, I have a problem to install the device for arduino leonardo for W 7

@villTech -- Thank you for posting what you discovered. That was the final clue to finally fix this. I spent too many hours trying to sort this out too.

I am running Win7 Ultimate 64, in a VM, on a MBP, but I doubt that has much to do with the actual problem or solution. I think the problem is a typo in the .inf file.

I changed three instances for the Arduino Micro in the .inf file and that solved my problem. In each case there was a mixed entry of VID/PID's mixing up an "8037" and "0037". Once they were all corrected to the "8037" as identified by Win7 as the VID/PID for the official Arduino Micro (all mine are from Adafruit), everything worked as expected.

My fixed .inf required changes to correct the VID/PID to "8037" in these three places:

[DeviceList]
.
.
%micro.bootloader.name%=DriverInstall, USB\VID_2341&PID_8037
%micro.sketch.name%=DriverInstall, USB\VID_2341&PID_8037&MI_00
.
.

[DeviceList.NTamd64]
.
.
%micro.bootloader.name%=DriverInstall, USB\VID_2341&PID_8037
%micro.sketch.name%=DriverInstall, USB\VID_2341&PID_8037&MI_00
.
.

[DeviceList.NTia64]
.
.
%micro.bootloader.name%=DriverInstall, USB\VID_2341&PID_8037
%micro.sketch.name%=DriverInstall, USB\VID_2341&PID_8037&MI_00
.
.

Obviously this has been around as a problem for a while. This issue has been discussed, but not solved in many threads and posts: http://forum.arduino.cc/index.php?PHPSESSID=9rlmc04rp6auovlpo8448o1784&topic=263483.0 http://forum.arduino.cc/index.php?PHPSESSID=98o9mp3ehsemsjb013dvhqcku3&topic=104698.msg924470#msg924470 http://forum.arduino.cc/index.php/topic,153674.0.html http://forum.arduino.cc/index.php/topic,177277.0.html

Does anyone know where to "officially" submit request to fix the typo in the .inf file?

--Jon