Leonardo not connecting

The other day I bought a Leonardo on Craigslist, and am having trouble connecting it. Here is what happens:

  1. When I start up Arduino IDE, even with the board plugged in and "Arduino Leonardo" preselected, the "Port" option under "Tools" is greyed out.
  2. If I then unplug the board and plug it back in, it appears on the list, but disappears again if I try to do anything.

The board itself is visibly on and seems to have some sort of a Fade-type program installed.

I also have an ELEGOO Uno that works just fine.

I am using Arduino IDE 1.9.0 Beta, although it doesn't work with the other version either. My computer is a Toshiba Satellite running Ubuntu 18.04. I've tried with several different USB cables.

Are there some drivers I need to install? Or is it maybe a hardware issue?

Thanks!

Could also take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

Then you will at least know that pictures can also be useful.

Also have you tried to double tap the reset button on the board to put it into bootloader mode ?
A different COM port will be shown for that aspect.

Just some random thoughts.

What do things like dmesg and lsusb say when you connect the board; what do they say after press and releasing the reset button.

When the boot loader is active, it will fade the led; usually around 8 seconds.

The boot loader is not active when you connect the Leonardo to a PC, only when you reset the Leonardo.

Craiglist is second hand stuff if I'm not mistaken; there is always a risk. But let's stay positive.

PS
No longer a Linux user, so might not be able to assist much.