Leonardo not detected by PC, but Uno is

Hi all,

I'm new on the forum, but not on the arduino familly.

I received 2 Leonardo for a simulator project, the problem is not one of them is detected by my computer.

Nothing under : PORT
Nothind under : Other devices
Not magical connection sound from microsoft.

(Yes I read a lot of forum before to post)

I tried the two board with 3 different Micro usb cables on 3 differents computers but nothing works...

Nevertheless my 2 UNOs boards are detected correctly without any problems...

I mean maybe it s the USB cable but i Tried 3 differents, on every ports on 3 different computers...

Is it possible that the firmare is not flashed on the board ?

Any idea if possible to do so and how ?

Best regards,

ArduinoIDE 1.8.12

When using the cables between a cell-phone and a computer, is the cell-phine recognised by the computer? If not, it's a charge-only cable.

If you bought an original Arduino, chances are very slim that the boot-loader is not burned. If you bought a clone, there is a chance.

You can find instructions about burning boot loaders on the web. You can use one of your Unos as programmer; there is a sketch for it in the examples (ArduinoISP).

Tested about 12 cables micro sub and I finally found one !

Why micro usb are not doing the same function and it s not precised on ?

Grrrrrrrrrrrrrrrrrrrr Thank you man

Some cables are just charging cables and the data lines are not connected , these won’t work !