Leonardo Pro Micro: bootloader doesn't respond after double RST

Hello, I hope I picked the right forum section for my question...

I needed my Leonardo Pro Micro to appear as a pure keyboard, so I had to flash a modified AVR version (from here: https://github.com/gdsports/usb-metamorph/tree/master/USBSerPassThruLine). It basically disables the board appearing as multiple devices which confuses BIOSes and other systems sometime.

Now, it cannot be flashed straight away, as it doesn't appear as a serial port any longer. However, I found that pressing RST button (connecting the pin to GND) twice makes it reset, start with the bootloader and appear as a serial device again.

The problem: after double-pressing RST and the board appearing as a serial device (/dev/ttyACM0) it automatically resets again after ~6 seconds and during these 6 seconds the Arduino IDE doesn't seem to be able to flash the firmware, even though it recognizes the device.

Is my Leonardo Pro Micro a brick now after such a modification or there're still ways to flash it? It's strange that the IDE is not able to upload the firmware while the device is in bootloader mode.

I'm using the default "AVRISP mkll" programmer as before, but also tried selecting "AVR ISP" with no effect.

I do click things fast in the IDE and the message "Uploading" appears after 2-3 seconds of resetting the board, so I'm pretty sure that I hit the 6-second window.

Click upload, when the Size is shown, double tap the reset! This should help.

it indeed worked! Thank you so much!!

What is the trick? Just the fact the it starts communicating very early, as soon as the bootloader comes online?

The uploader looks for a new COM port before uploading, this is created when you double tap RESET by the bootloader.