Leonardo Serial Monitor problem

I received my Arduino Leonardo today. I've found an USB cable from my Samsung Galaxy to hook it up to the PC. I've successfully uploaded the blink sketch, and I've also modified the values and re-uploaded and all seemed ok. The problem is that when i try to print something to the Serial Monitor, nothing happens. For debugging, I've created the following sketch.

void setup() {
  while (!Serial) {

void loop() {

After I upload it, the LED starts blinking 500/500 (indicating Setup function). When I open serial monitor, the LED keeps remaining ON for about 5-8 seconds, then it goes OFF for about half a second, and repeats this, until I exit the serial monitor. Then, it starts blinking rapidly. If I open serial monitor again, the LED comes back to the 5-8 seconds. And so on. In serial monitor, nothing is shown among all the test. What could the problem be ? I'm running Windows XP SP2, Arduino 1.0.1 IDE. I've tried two USB ports, but the problem persists.

Also, when I try to send something from serial monitor, the following appears beneath the sketch:

java.io.IOException: Input/output error in writeArray
    at gnu.io.RXTXPort.writeArray(Native Method)
    at gnu.io.RXTXPort$SerialOutputStream.write(RXTXPort.java:1124)
    at processing.app.Serial.write(Serial.java:517)
    at processing.app.Serial.write(Serial.java:540)
    at processing.app.SerialMonitor.send(SerialMonitor.java:200)
    at processing.app.SerialMonitor.access$100(SerialMonitor.java:32)
    at processing.app.SerialMonitor$4.actionPerformed(SerialMonitor.java:96)
    at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
    at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
    at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
    at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
    at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
    at java.awt.Component.processMouseEvent(Component.java:6263)
    at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
    at java.awt.Component.processEvent(Component.java:6028)
    at java.awt.Container.processEvent(Container.java:2041)
    at java.awt.Component.dispatchEventImpl(Component.java:4630)
    at java.awt.Container.dispatchEventImpl(Container.java:2099)
    at java.awt.Component.dispatchEvent(Component.java:4460)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
    at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
    at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
    at java.awt.Container.dispatchEventImpl(Container.java:2085)
    at java.awt.Window.dispatchEventImpl(Window.java:2475)
    at java.awt.Component.dispatchEvent(Component.java:4460)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

How can I solve those problems? Thank you very very much in advance!

Later Edit: Tried it on a laptop with Windows 7. Works like a charm, even with the code uploaded from WinXP. Seems like Windows XP has some problems handling serial data.

Yup. Confirmed here on two WinXP machines. One of the Leonardo guru's is looking into it we will see...

I Got the very same problem on XP SP3

Any news?

It worked for me with Windows XP SP3. Anyway, I'm using only Windows 7 now. Try installing Windows 7, and see how it works.

I Got the very same problem on XP SP3

Any news?

I don’t know what can be the problem, I’ve tested in XP SP3 and it´s working…
no idea what’s happening to you…
try to update your computer or check the com port

RuiSantos: I don't know what can be the problem, I've tested in XP SP3 and it´s working... no idea what's happening to you... try to update your computer or check the com port

I've already SP3, always uptodate, I think I have to format and reinstall, but I want to understand!

thanks Sergioc.

Hi all, I have the very same problem here (running Arduino on a winXP SP3 laptop). Did anyone fix it?

Hi all,
I have the very same problem here (running Arduino on a winXP SP3 laptop).
Did anyone fix it?

Negative. I surrended and I made a bootable linux on a USB…