LEONARDO USB PORT NOT WORKING

I had a leonardo lying around since a year ,
i wanted to use it with USB Host shield , and i wanted to emulate it
as mouse and keyboard
when i connected the usb cable to PC and Leonardo , (USB Port) , then
first time , it came "New Device Detected with a beep sound , Then
Arduino Leonardo Bootloader on COM4 ..."etc !
then i checked the arduino IDE (latest) ...there was no com port for
arduino leonardo !
so i reconnected it , and this time i got that sound again , and
nothing like arduino leonardo bootloader or something , but
"Unidentified USB device" in usb list !(dev manager)
I tried that Stuff , like changing cable , and PC for 3 Hours ! But
still no luck ! i had arduino drivers for leonardo and uno , installed
already ! still this problem was there ! so ,i thought that firmware
on leonardo had been wooshed , due to my previous code or something ,
and i decided to flash it again ! i did flash the bootloader on
leonardo using my UNO , and then still , the same thing is happening ,
!
i even tried uploading the Mouse and Keyboard Emulation Code to
Leonardo , but My usb does not recognize it !
Also i am able to upload the blink , and fade programs on Leonardo
using arduino Uno as programer ISP.

I have tried changing the cable 4 times , and Both of my PC's show me
the same condition !

I think the problem might be the Leonardo Micro USB Port !

can it be ?

if it is , what should i do ?

i am thinking about , cleaning it with rubbing alcohol !!

should i do it ?