Library does not appear in Manage Libraries

A library I installed recently (VarSpeedServo) by using Sketch > Include Library > Add ZIP Library does not appear anywhere in Manage Libraries. Yet I've used the library successfully in several sketches.

How can that arise please? Shouldn't it appear in the Installed category?

Terry, East Grinstead, UK

Hello Terrypin,

Thank you for sharing your question with the Arduino community.

Manage Libraries only shows the libraries which are in the Arduino Library Manager index (http://downloads.arduino.cc/libraries/library_index.json).

You can find your library in the following directory on your computer and in Arduino IDE under Sketch > Include Library:
C:\Users\user\Documents\Arduino\libraries

At some time in the past Manage Libraries did list all installed "custom" libraries in addition to the libraries available from Library Manager index, but that behavior was changed some time ago.

I hope this was helpful!

These steps may also save you some unnecessary time and effort in the forum.

nachoherrera:
Hello Terrypin,

Thank you for sharing your question with the Arduino community.

Manage Libraries only shows the libraries which are in the Arduino Library Manager index (http://downloads.arduino.cc/libraries/library_index.json).

You can find your library in the following directory on your computer and in Arduino IDE under Sketch > Include Library:
C:\Users\user\Documents\Arduino\libraries

At some time in the past Manage Libraries did list all installed "custom" libraries in addition to the libraries available from Library Manager index, but that behavior was changed some time ago.

I hope this was helpful!

Yes thanks @nachoherrera, it was. All understood. In fact I'd come to that conclusion about the distinction myself after further folder and file browsing yesterday. Although IMO the original structure makes more sense.

Terry, East Grinstead, UK