Library einbinden / FastLED / Noise Function

Hey Ihr,

ich verzweifle gleich: Neue Version von FastLED geladen, entpackt und ins library Verzeichnis kopiert. (Unter Ubuntu \sketchbook\libraries) IDE neu gestartet, neue Beispiele unter Examples gefunden.

Compilieren geht nicht, weil

Noise.cpp:1:20 fatal error: FastLED.h: Datei oder Verzeichnis nicht gefunden

Beide Dateien existieren in \sketchbook\libraries\FastLED und die Examples werden wie gesagt von der IDE gefunden.

Was läuft da schief?

Gruß

Helmuth

hast Du die Dateine der Bibiothek etwa unter \sketchbook\libraries\FastLED\FastLED ? indem Du das Verzeichnis erstellt hast und darin die zip Datei mit dem Unterverzeichnis entpackt hast?? Grüße Uwe

Nein, habe vorher das alte FastLED Verzeichnis gelöscht und dann die .zip nach \sketchbook\libraries entpackt. Dort gibt es jetzt ein \FastLED Verzeichnis mit einem einzigen Unterverzeichnis: \examples

Gruß Helmuth

Hallo,
du hast doch einen Sketch mit:

lösche die Zeilen einmal.

Dann in der IDE: Sketch → Library importieren.
Ich hoffe es hilft.
Gruß und Spaß
Andreas

hi,

meinst Du die vom 17.4. ? hab' ich grad runtergeladen, testsketch "blink" läuft. was ist noise.cpp? hab' ich nicht.

gruß stefan

@Skoby: Nee, hilft leider auch nicht.

@Eisebaer: Ich meine den Branch von letzter Woche: https://github.com/FastLED/FastLED/tree/FastLED2.1

noise.cpp implementiert mehrdimensionales Simplex/Perlin Noise und was die Leute damit machen, ist ziemlich abgefahren...

Videos hier: https://plus.google.com/communities/109127054924227823508 (ein bissl runterscrollen)

Bekommst Du das Beispiel Noise zum Laufen?

Gruß Helmuth

edit: Falls es interessiert, hier eine Einführung, was man mit Noise Funktionen machen kann und wie sie funktionieren: http://freespace.virgin.net/hugo.elias/models/m_perlin.htm

hi,

hat seltsam angefangen. beim ersten mal konnte er eine vorhandene core.a nicht überschreiben, beim zweiten mal hat ihm setup und loop gefehlt. ich hab' dann eine einfache beispieldatei kompiliert, und dann ging's auch mit noise. aber das hatten andere und ich auch schon mit anderen sketches...

andere idee: hast Du vielleicht im programmverzeichnis von arduino (auch dort gibt es einen libraries-ordner) noch eine alte version der fastled?

gruß stefan

Habe auf der gesamten Festplatte nur einen einzigen FastLED Ordner unter ...\sketchbook\libraries

Habe zum Test diesen wieder gelöscht und eine ältere Version installiert - funktioniert, wie gewohnt.

Wieder gelöscht und die neue Version nochmal installiert - gleiches Problem...

WTF?

Gruß Helmuth

hi,

ich hab' arduino 1.0.5, aber unter win7