Library File Not Found

Hello,

I am new to Arduino using 1.6.3. I am trying to install a new Library. I followed the .ZIP tutorial from the main page. The problem comes when i compile. I get an error:

Arduino: 1.6.3 (Windows 8.1), Board: “Arduino Uno”

Build options changed, rebuilding all

Using library SD in folder: C:\Program Files (x86)\Arduino\libraries\SD

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++ -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10603 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR -IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino -IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard -IC:\Program Files (x86)\Arduino\libraries\SD\src C:\Users\Brandon\AppData\Local\Temp\build7564647569186763718.tmp\Play_WAV_File_SD.cpp -o C:\Users\Brandon\AppData\Local\Temp\build7564647569186763718.tmp\Play_WAV_File_SD.cpp.o

Play_WAV_File_SD.ino:7:71: fatal error: TMRpcm.h: No such file or directory

compilation terminated.

Error compiling.

The file is installed per the instructions on the Library page. C:\Users\Brandon\Documents\Arduino\libraries\TMRpcm-master\TMRpcm. I tried moving the contents of TMRpcm up a subfolder but it still doesn’t recognize the library.

#include <SD.h>                      // need to include the SD library
//#define SD_ChipSelectPin 53  //example uses hardware SS pin 53 on Mega2560
#define SD_ChipSelectPin 10  //using digital pin 4 on arduino nano 328
#include <TMRpcm.h>           //  also need to include this library...

TMRpcm tmrpcm;   // create an object for use in this sketch
char mychar;

The code is taken from Maxoffsky.com’s project.

Thanks

I found my answer. Thanks.

OK one way, how about sharing your answer with the rest of us?

The “-master” at the end of the directory name is an artifact of how Github packages folders into a .ZIP file on demand. In every case I have seen you have to rename the library folder from “foo-master” to “foo” for everything to work well.

Also remember to re-start the Arduino IDE if you manually copy a library folder into your ‘libraries’ folder. It only scans your ‘libraries’ folder when it starts up.