Library not found - so where SHOULD it be?

I started my world of computing many decades ago, writing my own software, but since I found the joy of HW hacking there’s been no need.

But my son is 14 ad needs some GOOD distractions and he wants to learn to code and from everything I have read Arduino should satisfy both of us.

But its been longer than some of you have been alicve since Ive written anything other than an occasional script.

So when I try to assemble a simple MP3 player:

I found that instructables were not always meant to be a step by step guide, especially when step 1 is a doozy.

Got my screen wired up, got my UNO R3 ready and so as the 5th paragraph suggests I decide I should test it to make sure it works.

So I pull out the most disposable machine I have on hand, Win10 laptop with a dual core 1.2GHZ crippled pentium and as little of Win10 installed as I can get away with.

Install Arduino and IDE download the U8g2 library and decide to try one of the TEST sketches in this case space trash from: /U8g2-2.27.6/U8g2-2.27.6/examples/games/SpaceTrash

and start to upload the sketch and immediately rceive

*/

#include <Arduino.h>
#include <U8g2lib.h> <-------LIBRARY OR PATH NOT FOUND

Scrape the cobwebs off my brain, and I go looking for that library.

I found it and did some searches on the net and someone said place it in your user directory in your Arduino folder

So I copied the folder and al its subs, plopped it down there, tried to upload the sketch

SAME ERROR

So I copied the folder and its subs into EVERY location I ca THINK it MIGHT be looking - no go.

OK Well the author of the instructable said he has a self test I’ll try his!

just below paragraph 5 he has a sounpod.rar so I grab that unrar it

went to /soundpod/soundpod and tried Display.ino

almost the exact same error (not 100% but same concept)

So the challenge is that this very basic issue is that the upload is looking for a file in a specific place and its not finding it.

Which leaves me with one of 3 choices:

  1. Poke at it with a stock like I have been and keep copying the folder/files to different sub directories until I a)fill my hard drive or b) get it right )its only 500GB so Im shooting for a.

  2. wipe out the entire drive, seal off the OS on a sperate partition and ONLY nallow access to ONE area (seems rather extreme)

  3. ask folks who know,how this works where these files should be located

Prior to a GUI you set your PATH and everything looks there.

OR you write your “sketch” so it always looks in a common area for certain types of files. But that wa sthe OLDEN Days when programming was hard and Arcane Coding Wizards spoke in HEX!

I KNOW I am missing the basics, I know that I didnt start at step 1 and go to step10. I started at step27 and started moving OUTWARDS

But it seems to me that there should (?) be a common place for files like this to go abd I just dont knpow whgere its is, so if anyone would like to enlighten me I would love to learn!

Thanks

j

OK found my answer

and for anyone else stumbling around try this:

now I have a font that apparently wasnbt declared…

Arduino: 1.8.13 (Linux), Board: “Arduino Uno”

/home/jerome/Downloads/arduino/sketch/U8g2-2.27.6/U8g2-2.27.6/examples/games/SpaceTrash/SpaceTrash.ino: In function ‘void setup()’:
SpaceTrash:1681:3: error: ‘u8g2’ was not declared in this scope
u8g2.begin();
^~~~
/home/jerome/Downloads/arduino/sketch/U8g2-2.27.6/U8g2-2.27.6/examples/games/SpaceTrash/SpaceTrash.ino:1681:3: note: suggested alternative: ‘U8G2’
u8g2.begin();
^~~~
U8G2
/home/jerome/Downloads/arduino/sketch/U8g2-2.27.6/U8g2-2.27.6/examples/games/SpaceTrash/SpaceTrash.ino: In function ‘void loop()’:
SpaceTrash:1690:3: error: ‘u8g2’ was not declared in this scope
u8g2.setFont(u8g2_font_6x10_tr);
^~~~
/home/jerome/Downloads/arduino/sketch/U8g2-2.27.6/U8g2-2.27.6/examples/games/SpaceTrash/SpaceTrash.ino:1690:3: note: suggested alternative: ‘U8G2’
u8g2.setFont(u8g2_font_6x10_tr);
^~~~
U8G2
exit status 1
‘u8g2’ was not declared in this scope

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

just sayin…

You probably need to UNCOMMENT one of the constructor lines at the top of the demo file.

A large percentage of instructables are CRAP.