Library problem

I am attempting this tutorial:
http://www.e-licktronic.com/en/content/19-tutorial-library-srio

I have successfully installed the SRIO library and have started with the most simple program…
#include <SRIO.h>

void setup()
{
SR.Initialize();
}

void loop()
{
}

yet when I try to compile I get an error:
SRIO_midi_buttons_ino.ino: In function ‘void setup()’:
SRIO_midi_buttons_ino:6: error: ‘SR’ was not declared in this scope

What am I missing?

You are trying to call the Initialize() method on the object SR. But, you haven't created that instance.

If that instance is supposed to be defined in the library, the a link to the library would be good.

the library:

#ifndef SRIO_h
#define SRIO_h
#include "Arduino.h"

#define _latchPinOut 12
#define _dataPinOut 13
#define _latchPinIn 10
#define _dataPinIn 11
#define _clockPin 9

class SRIO
{
public:
void Initialize();
uint8_t shiftIn_SRIO();
void shiftOut_SRIO(uint8_t val);
void Led_SR_Write (byte SR_num, byte data);
void Led_Pin_Write (byte Pin_num, byte flag);
void Led_All_On();
void Led_All_Off();
byte Led_SR_Read (byte SR_num);
byte Button_SR_Read (byte SR_num);
byte Button_Pin_Read (byte Pin_num);
private:
byte _SR[8];
byte _data[8];
};

extern SRIO SR;

#endif // Fin si

the library:

And where do you have this library? Did you restart the IDE after installing it there?

In the librarys folder of the arudio program... also, just incase in the libraries folder created in mydocuments...

yes i´ve restarted program and even PC just incase.

In the librarys folder of the arudio program… also, just incase in the libraries folder created in mydocuments…

It doesn’t belong in both places. The first is wrong.

Are the SRIO.h and SRIO.cpp files in a folder called SRIO in the libraries folder?

yes both files are in the SRIO folder.

Compiling with 1.0.5

Post the SRIO.cpp file, and I'll try it out.

fixed

must be a permissions issue.. I ran arduino program as administrator and it worked..

thanks for your time