Library with serial interface for arduino MKR W1010

Hello all,

I'm using Arduino MKR with Next-PM sensor . I found PM serial library on GitHub:

PMserial/src at master · avaldebe/PMserial · GitHub.

But it is for Arduino esp8266, I tried a lot to figure out how to use it on my board but no success.

Could you help me please? It's urgent..

My sketch is simple:

#include <PMserial.h>

Uart Serial1(&sercom5, 13, 14, SERCOM_RX_PAD_3, UART_TX_PAD_2);

void SERCOM5_Handler()
SerialPM pms(PM, 13, 14);  // PM Serial, RX, TX

void setup() {
  pms.init();                   // config serial port

void loop() {;                   // read the PM sensor
  Serial.print(F("PM1.0 "));Serial.print(pms.pm01);Serial.print(F(", "));
  Serial.print(F("PM2.5 "));Serial.print(pms.pm25);Serial.print(F(", "));
  Serial.print(F("PM10 ")) ;Serial.print(pms.pm10);Serial.println(F(" [ug/m3]"));
  delay(10000);                 // wait for 10 seconds

Thanks in advance

you asked this on many places and I saw someone somewhere answered you how you should modify the library to use the built-in Serial1

you asked this on many places and I saw someone somewhere answered you how you should modify the library to use the built-in Serial1

Hi Juraj,

Yes you are right, he told me to: Replace HardwareSerial by Uart in the .h and .cpp files and use the constructor that provides the serial interface object as a parameter and not the pins.

I tried to do that but it didn't work, I replaced HardwareSerial.h by uart.h in the library(in .h and .cpp) (I found uart library on Github Arduino/cores/esp8266 at master · esp8266/Arduino · GitHub )

I'm a beginner in Arduino MKR, if you can help me I will appreciate that.


ok. there is no problem.
the library looks OK for MKR.

only use
SerialPM pms(PM, Serial1);

Serial1 is built in, don't create it with Uart Serial1(&sercom5....
it is on pins labeled RX/TX on MKR

hi guys:
I am working on a project that require Next-PM sensor. I wonder if anyone has library for Arduino MKR101?

and what is wrong with the existing library?
why do you ask this again?

no. I don't have the error. download the latest version of the PMSerial
I downloaded it here:

but it is not a valid Arduino library ( is missing), so only put the files PMSerial.h and PMSerial.cpp in a folder named PMSerial in libraries folder

but "'NextPM' was not declared in this scope"

Thank you very much Juraj , it works..


Moved and MERGED your topic to it's current location / section as it is more suitable.
Please do NOT cross post / duplicate as it wastes peoples time and efforts to have more than one post for a single topic.

Continued cross posting could result in a time out from the forum.

Please take a few moments to Learn and Use The Forum

How to get the best out of this forum Installation & Troubleshooting

Hello, Welcome to the Arduino Forum. This guide explains how to get the best out of this forum. Please read and follow the instructions below. Being new here you might think this is having rules for the sake of rules, but that is not the case. If you don’t follow the guidelines all that happens is there is a long exchange of posts while we try to get you to tell us what we need in order to help you, which is frustrating for you and frustrating for us. The people who try to help with your pro…

It will help you get the very best out of the forum in the future.

  • Your OS and version can be valuable information, please include it along with extra security you are using. Antivirus etc.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks sterretje )
  • Add your sketch where applicable but please use CODE TAGS
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can


  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102 or FT232 VCP Drivers - FTDI
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.


  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent


  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.

Language problem ?

Try a language closer to your native language:

Thanks to all those who helped and added to this list.