libXtst.so.6: cannot open shared object file: No such file or directory

Dear All,
Getting below error when I launched new arduino on my Linux Ubuntu 14.04 64bit PC.

Also I tried to run as root.
Removed complete JAVA on my PC.

titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION=“Ubuntu 14.04.1 LTS”
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$ uname -a
Linux tituspc 3.13.0-86-generic #131-Ubuntu SMP Thu May 12 23:33:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$ ./arduino
Picked up JAVA_TOOL_OPTIONS:
Exception in thread “main” java.lang.UnsatisfiedLinkError: /home/titus/workdir/arduino/arduino-1.6.12/java/lib/amd64/libawt_xawt.so: libXtst.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824)
at java.lang.Runtime.load0(Runtime.java:809)
at java.lang.System.load(System.java:1086)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1845)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1122)
at java.awt.Toolkit$3.run(Toolkit.java:1636)
at java.awt.Toolkit$3.run(Toolkit.java:1634)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Toolkit.java:1633)
at java.awt.Toolkit.(Toolkit.java:1668)
at cc.arduino.view.SplashScreenHelper.(SplashScreenHelper.java:54)
at processing.app.Base.(Base.java:88)
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$ ./arduino^C
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$
titus@tituspc:~/workdir/arduino/arduino-1.6.12$ sudo su
[sudo] password for titus:
root@tituspc:/home/titus/workdir/arduino/arduino-1.6.12#
root@tituspc:/home/titus/workdir/arduino/arduino-1.6.12#
root@tituspc:/home/titus/workdir/arduino/arduino-1.6.12# ./arduino
Picked up JAVA_TOOL_OPTIONS:
Exception in thread “main” java.lang.UnsatisfiedLinkError: /home/titus/workdir/arduino/arduino-1.6.12/java/lib/amd64/libawt_xawt.so: libXtst.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824)
at java.lang.Runtime.load0(Runtime.java:809)
at java.lang.System.load(System.java:1086)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1845)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1122)
at java.awt.Toolkit$3.run(Toolkit.java:1636)
at java.awt.Toolkit$3.run(Toolkit.java:1634)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Toolkit.java:1633)
at java.awt.Toolkit.(Toolkit.java:1668)
at cc.arduino.view.SplashScreenHelper.(SplashScreenHelper.java:54)
at processing.app.Base.(Base.java:88)
root@tituspc:/home/titus/workdir/arduino/arduino-1.6.12#

What could be the problem ?
Can you please support on this problem ?

Regards,
Titus S.

Tried to run the 32bit version of the latest arduino IDE and its running without any problem. It seems issue is with 64bit version in 64bit HW.

Try

sudo apt-get install libxtst6