LIGAÇÃO MOTOR DE PASSO

Galera, todas as ajudas foram muito bem vinda e eu já consegui fazer o programa (até testei em um simulador e deu certo), só que agora to fazendo a ligação do protoboard, eu estou usando o CI que é o ULN2003 só que eu vi no site do arduino que tem umas resistencias de 1Kohn ligada junto ou eu to ficando maluco ? pq pelo que eu tinha entendido a ligação era bastante simples, se não for algm me corrija + para mim era assim:

1- Alimentar o ULN2003 (pino 8 e 9)

2- Ligar as 4 saídas do ARDUINO nos 4 primeiros pinos do ULN2003 (as saidas que foram iformadas no programa, no meu caso 8-9-10-11)

3- Ligar os 4 fios do motor nos outros 4 pinos do CI (pinos 13-14-1-16)

é so isso não é ? pq la pelo esquema do site da arduino estão apenas 2 fios do microcontrolador ligado no CI algm pode ver se estou fazendo algo errado ^???

Breno,

existem duas maneiras de usar, uma é com dois pinos e outra com 4 pinos, a versão de dois pinos, usa os resistores de 1K a de 4 pinos não usa nada. http://arduino.cc/en/Reference/StepperUnipolarCircuit

Não se esqueça que para acionar um motor de passo a sequencia correta de fases deve ser respeitada, caso contrario ele não gira.

existem duas maneiras de usar, uma é com dois pinos e outra com 4 pinos, a versão de dois pinos, usa os resistores de 1K a de 4 pinos não usa nada. http://arduino.cc/en/Reference/StepperUnipolarCircuit

A ligação com resistores, é para controlar usando apenas 2 pinos do Arduino, no seu caso, como seu propósito é simples, pode ligar diretamente, usando o esquema "four pins" que está no link, mas os dois esquemas são validos.

Vlw galera

eu consegui ligar meu motor de passo xD

agora so + uma pergunta e finalizo meu projeto xD:

1-O meu CI (ULN2003) está esquentando de mais, e eu estou aplicando tensão certa nele (FONTE EXTERNA DE 300mA e 5V), isso é normal ?

2-O meu motor no sentido horario está girando corretamente, mas se no programa eu mudo o valor do passo para por exemplo (-50), ele não gira no outro sentido e o pior o que acontece é que o motor fica dando umas travada, o que fazer ?

Você está com 2 provaveis problemas:

  • o seu motor usa mais de 500mA de corrente ou muito próximo disso.

  • provavelmente a ordem dos fios não está correta.

O que acontece quanto à aquecer é que seu motor está consumindo demais, pode ser uma bobina com defeito (o que explica os dois problemas), ou pode ser simplesmente característica dele.

Tenta usar dois ULN em paralalelo (isso é um baita de um xunxo mas funciona :D), tipo, liga pino a pino 2 ULNs (1 com 1, 2 com 2, etc...dá até para soldar um em cima do outro).

E quanto a ele travar no sentido contrário, o que pode estar acontecendo é que às vezesvocê liga ele de uma certa forma que ele gira, mas a ordem dos fios não está correta, se você girá-lo devagar você o verá pulando algum passo em algum momento, ou enroscando.

Se não for isso, sinto informar-lhe que seu motor está com defeito...

putss

eu vi é isso mesmo meu motor consome 1,6A =/ e o ULN2003 so aguenta 500mA, oq eu faço ? tem como limitar essa corrente que o motor consome ? ou vou ter que utilizar outro CI ? qual ?

a ordem dos fios, como eu faço para descobrir pq pelo que eu vi na saida do CI eu tenhu q ligar os fios em sequencia (A1 , A2, B1, B2) como eu descubro isso ? ou é so testando mesmo ?

Voce pode colocar uns fets an saida e aumentar a corrente

Só lembra de dar um pouco de atenção à fonte. ;)

1-FETS

2-Italo o que a fonte tem q ver com meu motor ? pq tipo o ULN2003 aguenta ate 0,5A e meu motor é de 1,6A do mesmo jeito nao vai aguentar =/ ou se eu colocar uma fonte com uma corrente maior ele para de esquentar ?

Não sei se 2003 tem algum tipo de proteção mas se colocar uma fonte que possa disponibilizar mais corrente que o ci pode chavear, deve torrar o CI. Você pode trocar de motor e pegar um com corrente igual a máxima do CI, ou você vai ter que utilizar transistores (como IRF 620 capaz de gerenciar bem mais que 1,6A). Pra isso existe o ci L297 que inclusive pode fazer controle da corrente, ele é muito utilizado pelo pessoal dessa área, a coisa começa a ficar um pouco mais profissional.

2-Italo o que a fonte tem q ver com meu motor ? pq tipo o ULN2003 aguenta ate 0,5A e meu motor é de 1,6A do mesmo jeito nao vai aguentar

Amigo, a fonte tem tudo a ver com o motor, se o seu motor consome 1,6A, ele vai tentar puxar essa corrente dfe algum lugar, se a fonte tiver proteção, ela irá cair a tensão, até que a corrente obtida seja suportada, se não ela irá explodir, pegar fogo, algo do tipo…

quanto ao uln2003, se ele suporta 500mA, e seu motor consome 1,6A não tem como usá-lo, ele irá queimar com certeza e provavelmente poderá queimar seu Arduino também se os pinos entrarem em curto ao queimar.

procura no google driver de motores com mosfets, ou com transistores. Tem vários esquemas, funcionam da mesma maneira que o uln, só que ocupa mais espaço (e consome mais corrente).

Dá uma olhada aqui para ter apenas uma ideia, adapta para o Arduino... http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1259117127

PS nesse motor de passo (teoricamente unipolar) esta faltando uma bobina, mas o que te interessa são os Fets ;D