light controlled bot

Im working on a project which cycles through stop,forward, back,left, right modes of a bot using light pulses as input .
light source is laser pointer , room is dark
the circuit is not mounted on the bot, separated by long wires to the 2 dc motors of bot
the circuit -
light pulse -> ldr-> bc337 transistor -> 7404 NOT->4017 decade counter ->7483 full adder -> l293d (10Volt)-> bot
bug - the 7404 inverter out is rising even at falling edge of light pulse
however it works fine with motor supply =6 v and also when dc motor is not connected to l293d
schematic below
is the circuit correct?
any thoughts please help

Hi;

the circuit is not mounted on the bot, separated by long wire

Can you post a picture of your project?
Separated by long wire, just one wire, or a pair for current return?

You have told us when it works.
When doesn't it work?

Tom... :slight_smile:

[/quote]

TomGeorge:
When doesn't it work?

when vcc2 (dc motor supply)of l293d is at +10V

Hi,
What is the 10V supply, batteries, power supply?

Tom... :slight_smile:

TomGeorge:
Hi,
What is the 10V supply, batteries, power supply?

10 V (2amp) ac - dc power adapter

Hi,
Have you got the negative of the 10V supply connected to the L239 gnd.
Can you post a picture of your project?

Thanks.. Tom.... :slight_smile:

TomGeorge:
Hi,
Have you got the negative of the 10V supply connected to the L239 gnd.

Yeah

Hi,
Why haven't you got Vcc1 connected to 10V as well?
Do you still have 5V supply connected to power the digital chips?

Tom.. :slight_smile:

TomGeorge:
Hi,
Why haven't you got Vcc1 connected to 10V as well?
Do you still have 5V supply connected to power the digital chips?

Tom.. :slight_smile:

yes i have a different ac-dc adapter( 5 V, 1.5 amp) to power digital chips

Hi,
Why haven't you got Vcc1 connected to 10V as well?

Tom... :slight_smile:

i wasnt sure if its safe
l293d datasheet texas instruments says
recommended operating voltage for Vcc1 is 7V max

Hi,
Sorry yes, my mistake, Vcc1 internal logic = 5V

With a DMM can you see the digital inputs to the L293 working the same with either motor supply voltage?

Tom... :slight_smile:

DMM reads fine when dc motors not connected to l293d driver outputs
but as i said in post #1 with motors connected and vcc2=10v,
at falling edge of light pulse, vout of bcc337 gives rise-fall-rise but it should only rise only 1 time
so, all further outputs skip 1 mode. so, l293d driver inputs are wrong

Hi,
Can you post a clear picture of your project please?

Thanks.. Tom... :slight_smile:

Replace the 7404 with a 7414 (Better still, 74HC14). You need schmitt-trigger to cleanup
the analog output from the light sensor, otherwise you will get multiple transitions.