Lilypad not uploading code from Arduino on Mac OS Sierra

Hi, I have a Lilypad Arduino and a Mac OS Sierra.

I tried to upload a very simple code on my Lilypad today and it hasn't worked.
After that I went on Sparkfun and found the instructions about the FTDI drivers:

https://learn.sparkfun.com/tutorials/how-to-install-ftdi-drivers/mac

This information suggested me to download the FTDI Drivers, and also to disable Apple's drivers, since apparently there have been issues with the built in Apple VCP Drivers from Mac OS 10.9 (Mavericks) and later.

I did all that was suggested and the answer is: STILL NOT WORKING.

Then I went further and found this thread in the arduino forum

MacOS Sierra does not find USB connection to FTDI (Read 16681 times)

This topic is from one year ao, and I found it unhelpful, since I uninstalled the FTDI drivers, rebooted and STILL NOT WORKING.

Can someone please update the FTDI Drivers information for Mac OS Sierra users?

I spent the last 5 hours trying to figure out why Arduino won't upload the code to my Lilypad.

After trying 2 different Lilypads, installed and uninstalled the FTDI Drivers, rebooted, read a few more irrelevant posts, the result is always this error below:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding

I am at total loss on what to do, and have an assignment due on Tuesday. No way I can do anything in this state and am really frustrated :frowning:

Does someone have any help?

Thanks a lot. I do hope a savvier mac user has found the solution

Did you get an answer. Having the same problem. :frowning:

Interesting. I'm having trouble using 1.8x to flash an EL Sequencer (a SparkFun board where the docs say to specify the LilyPad board).

I've flashed them before on my Mac, but wasn't exactly surprised that I was having trouble today (given the unending cluster that is Apple/FTDI serial driver support).

When my Windows box also couldn't flash them, I started to wonder if there's a more general problem here and found your post.