lilypad usb blinks alot and makes a hiss sound

This has occurred since receiving the device, I'm getting the feeling it shipped without the magic smoke. As soon as the lilypad is plugged into my computer it starts to make a subtle high pitch whining sound almost like what you would expect to hear from a dc wall adapter. The two smd leds alternate in the following manner unmarked (pin 13?) twice, rx once. To me it looks like it is constantly resetting.

It takes a while for the ide to recognize the serial port its on, but I made sure the board and port were set right. When I try to upload the tx and rx will light but ultimately it feel as though it is interrupted by the odd blink sequence described above with vary frequencies of hissing. Then followed by this message from the ide.

Binary sketch size: 4,600 bytes (of a 28,672 byte maximum) Couldn’t find a Leonardo on the selected port. Check that you have the correct port selected.  If it is correct, try pressing the board's reset button after initiating the upload.

Tried the reset after initiating the upload I managed to upload a sketch once a couple of days ago but was unable to repeat the same upload. Is the lilypad usb supposed to hiss? I just get the feeling its cooked I got this for christmas... do you think sparkfun would trade me for a working one?

Are you absolutely sure you have the right driver installed? I'll be honest, I don't know if the Lily Pad uses the 'Leornardo' driver, but that looks a little wonky to me.

I don't know if the Lily Pad uses the 'Leornardo' driver

I think that the MEGA32u4 chip is generally referred to as the Leonardo since it uses that chip. I used a usb 1.1 hub for the arduino micro and got a similar error referring to the micro (also a MEGA32u4) as the Leonardo (using a usb2 port remedied that specific issue, took me a while to figure that out though)

Are you absolutely sure you have the right driver installed?

I didn't think of that, never had to bother with them in linux for the uno or the micro. Maybe there is no automagical secret sauce for the lilypad? Though I would think the drivers are the same for the Leonardo / Micro / usb lilypad

Sparkfun is sending me a new board, problem solved

… and the new board does the exact same thing right out of the box…

on this page( ) it says to reset the the boot-loader by double clicking reset on upload.

I’ve tried that with both in various manners

I must not be the only one with this problem, is there anyone with a usb lilypad that can give me a step by step on your upload process?

Are you doing this exactly? Looks like a secret handshake kind of thing.

To upload with this technique, first press the upload button in the Arduino software; then, when you see the status message “Uploading…” press the reset button twice. This should initiate the bootloader, and the Arduino software will upload your sketch. You might have to play a bit with the relative timing of pressing the upload button in the software vs. the double-press of the reset button on the board.

Yeah, I think I have the timing right, I tried a couple of different ways. I can see the tx and rx blink rapidly on the double press and rx flashes a bit before the upload fails. I get the "couldn't find on port error". After that I notice that tx and rx blink rapidly again and it goes back to "breathing" as mention in the link.

One time out of ten I'll get a different error... I should have wrote it down, because I cant remember what it is now.

What version of Windows are you using?

I'm using 64 bit Mint linux 14 with the 1.0.3 version of the ide. Yesterday I did some test with the 1.0.4 version of the ide also with no luck.

It would make sense If the lilypad was being sent the wrong serial signal at the wrong times (1200 baud I believe it said). I'm not quite sure how to test that though. I have an Win xp machine lying under my junk somewhere maybe I can blow the dust off and see if its a platform issue.

Linux is 'cool' but XP might a little more forgiving. See if you can get that mule lit up. I forgot too much about UNIX to help out much...I remember I hated SMIT.

I just uploaded the sketch from another linux machine I have... and everything worked... :D

Eliminating the defectiveness possibly in the lilypad and turning the focus on my main machine... Which I would like to use because I'm giving the other computer away today... ironically because I didn't have a use for it...key word being didn't

maybe a rare 64 bit bug? This is one of the only differences between this and the other machine, I'm going to see if the jre needs to be updated next

Well, backward compatibility problems are frequently the issue. On one hand, a developer wants to try new tools and techniques, but on the other is the user that gets the proverbial "short end of the stick". Who is the ultimate decision maker? $$$$$ The financial dude (dudess).