Linux ch341 not working - D1 Wemos mini

Did any one get the ch341 driver and a cheap copy of an arduino such as d1 wemos to work on the newer Linux kernels? I am on arch linux with the following kernel:
Linux flash 5.14.9-arch2-1 #1 SMP PREEMPT Fri, 01 Oct 2021 19:03:20 +0000 x86_64 GNU/Linux

I also tried to install the following package from the aur.
aur/ch34x-dkms-git

But I still can't still get it to work and it won't even show up inside of the Arduino ide /dev/ttyUSB
I read that a lot of people have problems with it lately, but I wanted to know if anyone has been able to fix it?

I have Mint Linux. The CH340 devices that I connected were found and "just worked". No driver installation was required. Have you tried running system updates?

Hi !

Same thing with Ubuntu, no driver installation needed for CH34x.
No problem, no fix needed.... at this time
(but only kernel up to 5.13.0-21....)

some old stuff (2018) here @WCH site http://wch-ic.com/downloads/CH341SER_LINUX_ZIP.html

Ubuntu 18.04 had the defective ch34x driver for a few months. I ran an older kernel to get around the broken driver. The problem started in August so I did not have to very far back to find a kernel with a working driver.

The latest 18.04 kernel has the fix so it works fine. Not sure about other distros.

The root problem: https://bugzilla.kernel.org/show_bug.cgi?id=214131

Note the device /dev/ttyUSB0 appears but the ESP8266 upload times out.

When or if the problem and the revert bubbled up to your distro I have no idea. You may need to examine changelog for your distro kernel.

it won't even show up inside of the Arduino ide /dev/ttyUSB

If /dev/ttyUSB0 does not appear at all, the failure could be due to a bad USB cable (also known as power only USB cable).