Linux Environment is dead

I have Yun connected with Motor Shield. I tried powering the MotorShield with 9V battery and Yun from Motor Shield.

However, as soon as I connected the battery, the Linux environment stopped working. The Arduino environment is up and is functional but the Linux environment is completely dead. The power LED is not ON either. I tried using YunSerialTerminal example but that also left me with black terminal.

Have I burned the 3.3V regulator?

Yun should be strictly powered by 5V DC.

The Atmega section takes 5V while the Mips section just takes 3.3V through a switch regulator.

See here http://arduino.cc/en/uploads/Main/arduino-Yun-schematic.pdf for details.

There's an over-current function but that should just protect the pins from massive external juice sucking, I'm not sure.

Maybe powering the Yun from the shield (9V) fried the lower voltage tolerant wifi-linino side, leaving the Arduino side surviving from the shock.

Repairing it could not be possible or feasible.

You still have a perfectly working Leonardo, cheers! (sorry, silly joke :D )

I wonder if I fried MIPS or just the power regulator? Is there a way to check?