Linux Serial Communication Difficulty

Hi All,

I’m having some difficuly getting a machine running Debian to communicate with the Arduino UNO. This application has absolutely no problems communicating with the Arduino Duemilanove through ttyUSB0.

When I connect the Arduino Duemilanove to the PC /dev will populate with ttyUSB0.

If I disconnect the Duemilanove and re-connect an Arduino UNO I do not see ttyUSB0 or ttyACM0…

Things I’ve tried: • I can connect to the UNO through Windows Vista so I know the Arduino works. • From my understanding the 8u2 USB to Serial IC uses usbcore - If I do a “lsmod” I can see usbcore running. • If I run the “lsusb” command I can see the UNO as: “Bus 002 Device 005: ID 2341:0001.

So why is /dev not populating with ttyUSB0 or ttyACM0 ?


have you tried to run..

'sudo modprobe cdc_acm'. If that still won't work, show me your lsmod output. Maybe I can help. Good luck.

I just had the same issue its cleared up by updating the firmware on the uno. This post explains the process well -- >,38112.msg282438.html#msg282438 :)