Liquidware Slide issues

Hi all,

Got my gadget kit the other day with a touch slide (very snazzy) but I cannot seem to get the slide to work. I've dug around, tried many directions, watched several tutorials, loaded and reloaded various versions of the antipasta IDE, and nothing wants to work.

I'm pretty new to the arduino community (read noob), but I'm comfortable with electronics, and haven't had any issues writing to the arduino itself (the pin 13 blink program works a treat). However, doing ANYTHING to the slide shield I got is a FAIL. Including clearing everything out to a black background, or no program.

I set the board to the slide, press the little button, and hit upload. The IDE says uploading, then coughs up this:

Connecting to programmer: . Found programmer: Id = ""; type = (there is a box here) Software Version = >. ; Hardware Version = .Ø avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device?

Anyone have any ideas?? :'(

I forgot to mention that the touch slide IS working otherwise; the demo drawing app that was on there seems to work fine (color and brush selection on a black background).

I’m not having any problems with my slide, although I had to hack what I downloaded somewhat to get it off the ground.

  1. Have you downloaded the slide core and put it into the cores directory and update your boards.txt file OR use the liquidware arduino distribution?
  2. Have you selected the slide in your boards menu?
  3. Do you have a good connection between your Arduino and slide?

This is about all I know to offer with the details I have in hand here. Maybe ship a question to Justin over at Liquidware, maybe he’s will to help get you off the dime.

Good luck!

Greetings,

I'm having the same trouble here. I have taken the suggested steps as listed above with no success. I even swapped USB cables and ports just to make sure it wasn't an issue with that.

Any other ideas would be great! I am fearing a hardware problem.

Thanks in advance,

Byron

P.S. it is a windows xp sp3 system. Arduino Duemilanove w/Atmega 328 and touchshield slide.

Greetings,

i get the same error. I've an Arduino Mega Board and the Liquidware Slide Shield.

Has anybody solved this problem?

Thanks Martin

Hey Guys,

i solved this problem. it was a handling error. you have to push the S2 Button on the Touch Shield before starting an upload via USB. The Shield turns into an programming mode and a red LED burns.

Greetings, Martin

Ok, bumping this topic…

Tonight I found that any serial output from the Arduino (i.e. using Serial.print( ) for debugging) can prevent the Slide from getting the upload, resulting in this error message. Be sure to disable any serial output before starting the upload and all should be good.

I am still unable to upload the ShapesRandom example with Arduino 0018-Antipasto-0041.

The Slide works in demo mode with the drawing example.

I can compile the code fine. I selected TouchShield Slide under Tools->Boards. I switched the TouchShield Slide into programming mode, by pressing the button on the side of the unit, and I get this error when I try to upload.

I am able to upload the simple Blink example sketch to the Arduino Duemilanove, so I know the USB upload connection works.

Any help is appreciated.

Thanks

The error I get is:

[echo] Building TouchShield Slide libraries... [echo] Building TouchShield Slide board target... [echo] Building ShapesRandom for the TouchShield Slide core... [echo] Calculating ShapesRandom size... [echo] Binary Sketch (23546 of 250000 bytes, 9.4184%)

BUILD SUCCESSFUL Total time: 4 seconds [echo] Uploading ShapesRandom to board... [exec] [exec] avrdude: Version 5.4-arduino, compiled on Oct 9 2007 at 11:20:31 [exec] Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ [exec] [exec] System wide configuration file is "../..//../../../tools/avr/etc/avrdude.conf" [exec] User configuration file is "/Users/kietcallies/.avrduderc" [exec] User configuration file does not exist or is not a regular file, skipping [exec] [exec] Using Port : /dev/tty.usbserial-A800eJ2x [exec] Using Programmer : butterfly [exec] Overriding Baud Rate : 57600 [exec] AVR Part : ATMEGA2560 [exec] Chip Erase delay : 9000 us [exec] PAGEL : PD7 [exec] BS2 : PA0 [exec] RESET disposition : dedicated [exec] RETRY pulse : SCK [exec] serial program mode : yes [exec] parallel program mode : yes [exec] Timeout : 200 [exec] StabDelay : 100 [exec] CmdexeDelay : 25 [exec] SyncLoops : 32 [exec] ByteDelay : 0 [exec] PollIndex : 3 [exec] PollValue : 0x53 [exec] Memory Detail : [exec] [exec] Block Poll Page Polled [exec] Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack [exec] ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- --------- [exec] eeprom 65 10 8 0 no 4096 8 0 9000 9000 0x00 0x00 [exec] flash 65 10 256 0 yes 262144 256 1024 4500 4500 0x00 0x00 [exec] lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00 [exec] hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00 [exec] efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00 [exec] lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00 [exec] calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00 [exec] signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00 [exec] [exec] Programmer Type : avr910 [exec] Description : Atmel Butterfly Development Board [exec] [exec] Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding

BUILD FAILED /Applications/Arduino.app/Contents/Resources/Java/hardware/arduino/cores/touchshield/build.xml:151: The following error occurred while executing this line: /Applications/Arduino.app/Contents/Resources/Java/hardware/arduino/cores/touchshield/src/template/build.xml:179: The following error occurred while executing this line: /Applications/Arduino.app/Contents/Resources/Java/hardware/arduino/cores/touchshield/config/build.ccmacros.xml:45: exec returned: 1

Total time: 5 seconds

OK, removing the compass module solved the issue. It uploaded the example sketch.

Further investigation shows that the TouchShield Slide does not upload when set on the half of the Double Wide ExtenderShield above the Arduino.

Hi Kiet Callies, I am getting the same error when I try to upload. did you manage to solve this?

Eric

Ekiss,

I had the exact same problem and have contacted Liquidware. It was very frustrating and I tried every solution posted on every forum that I could find. I spend probably 20 hours on it. Nothing worked at first.

That is, until I tried uploading on an Arduino Duemilanove instead of an Arduino MEGA. Problem solved. Then I can move it over to the MEGA and use it there.

If you don’t have a Duemilanove, it costs under $30. Hopefully, it is a software issue that Liquidware can fix without making everyone buy the Duemilanove.

Dullard

Ok, I have a write-up over here: http://www.liquidware.com/start

I think mostly the issue is that the Slide requires the Antipasto Arduino IDE to work, since it uses a different chipset than the Arduino has, and therefore the Arduino 0018 IDE doesn't come with it, so I've always maintained a branch of the IDE myself:

http://www.liquidware.com/antipasto_arduino_ide

Hope this works...