Livebox + routeur wifi + Arduino en serveur

Bonjour à tous,

J'espère tout d'abord n'enfreindre aucune règle du forum en postant ici. J'ai préalablement cherché la réponse sur des posts existants, mais rien n'y fait.

Je souhaiterais mettre mon arduino en serveur, afin qu'il héberge quelques lignes HTML, que je puisse lui envoyer des requêtes, et qu'il agisse en fonction.
Grace a différents tutoriels trouvés sur internet, j'ai parfaitement réussi à coder ce que je souhaitais, et a obtenir les résultats escortés lorsque le module shield est directement connecté à la box. Mais je rencontre des problèmes lorsque je branche le module shield sur un simple routeur wifi, qui lui même est relié à la box. Voici un petit dessin pour être plus clair (cliquez pour agrandir) :

A savoir que le but est d'obtenir la page web envoyée par Arduino, lorsque je me rend à l'adresse : http://monip:4200/, et ce depuis n'importe quel réseau mondial.
Le problème vient très certainement de la configuration des routeurs/box.

A noter que sur la Business Livebox je peux ouvrir des ports de n'importe quelle adresse, mais que sur le routeur Netgear, je ne peux ouvrir que des ports sur la plage 10.0.0.0/255

Si certain auraient une idée, je suis preneur !

Merci beaucoup.

Cordialement,

Laigoh

ton routeur Netgear a t'il une réelle utilité dans ton réseau (un simple switch aurait il suffit) ?
sa config avec une adresse dans la classe A (non routable) et un masque de classe C est elle volontaire ?

bonjour,
j'ai la flemme de ressortir ma BLB pour vérifier si on peut router comme tu le fais.

en plus, tu route 3 fois le 4200
ton routeur doit avoir une ip en 192.168.1.x via la LB
de mémoire le 4200 est ead-web en reverse proxy et consultable si le service est actif via les fichiers conf.

question a se poser
puis je accéder à internet via le router?

mets en WAN une ip fixe en 192.168.1.10 (exemple) avec passerelle 192.168.1.1 mask 255.255.255.0 DNS 8.8.2.2
en configuration réseau adresse ip 10.0.0.1 mask 255.255.255.0 passerelle 10.0.0.1 DNS 8.8.2.2

routage du port sur la BLB
192.168.1.10 entrant 4200 sortant 4200

sur le routeur
10.0.0.120 entrant 4200 sortant 4200

rjnc38:
ton routeur Netgear a t'il une réelle utilité dans ton réseau (un simple switch aurait il suffit) ?
sa config avec une adresse dans la classe A (non routable) et un masque de classe C est elle volontaire ?

Bonjour,
La Wifi nous est utile, oui.
Ces classes d'adressage ont été réglées de la sorte par défaut, mais dois-je comprendre que je dois régler l'adresse en classe B ou C pour pouvoir arriver à mon objectif ?

infobarquee:
bonjour,
j'ai la flemme de ressortir ma BLB pour vérifier si on peut router comme tu le fais.

en plus, tu route 3 fois le 4200
ton routeur doit avoir une ip en 192.168.1.x via la LB
de mémoire le 4200 est ead-web en reverse proxy et consultable si le service est actif via les fichiers conf.

question a se poser
puis je accéder à internet via le router?

mets en WAN une ip fixe en 192.168.1.10 (exemple) avec passerelle 192.168.1.1 mask 255.255.255.0 DNS 8.8.2.2
en configuration réseau adresse ip 10.0.0.1 mask 255.255.255.0 passerelle 10.0.0.1 DNS 8.8.2.2

routage du port sur la BLB
192.168.1.10 entrant 4200 sortant 4200

sur le routeur
10.0.0.120 entrant 4200 sortant 4200

Bonjour,
Je ne suis pas sûr d'avoir compris. Vous me demandez d'essayer si je peux recevoir internet depuis mon routeur ? Mais mon routeur distribue déjà internet avec son réseau wifi/cablé. Pouvez vous détailler s'il vous plait ?

Vous parlez de cette page de configuration ?

Merci à vous deux pour vos réponses.

bonjour
je prend là le topic
Je ne suis pas un spécialiste du routage internet , mais ce ne serait pas "simplement" du au probleme de "loopback" bien connu sur les livebox ?